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Introduction to Microsoft PowerPoint

Title: What is Microsoft PowerPoint?
Content:
• Definition: PowerPoint is a presentation software application developed by Microsoft, 

part of the MS Office suite
• Primary Purpose: Create professional, engaging presentations using slides that combine 

text, images, charts, and multimedia
• Key Applications:

• Academic presentations and project reports
• Technical documentation and engineering proposals
• Training materials and instructional content
• Business presentations and product demonstrations



Introduction to Microsoft PowerPoint

• Why PowerPoint for Engineers?
• Communicate technical concepts visually
• Present project results and data analysis
• Create circuit diagrams and system architecture presentations
• Document laboratory experiments and findings

Practical Example:
• Engineering applications: Design reviews, project proposals, thesis defense 

presentations



PowerPoint Interface Overview

Title: Understanding the PowerPoint Workspace
Content:
• Ribbon Interface: Organized tabs containing related commands

• Home, Insert, Design, Transitions, Animations, Slide Show, Review, View
• Main Components:

• Title Bar: Shows file name and program name
• Quick Access Toolbar: Frequently used commands (Save, Undo, Redo)
• Slides Pane: Thumbnail view of all slides (left side)
• Slide Editing Area: Main workspace for creating content
• Notes Pane: Add speaker notes below the slide
• Status Bar: Displays slide number, theme, view options



PowerPoint Interface Overview

• View Options:
• Normal View: Default editing view
• Slide Sorter View: Organize and reorder slides
• Reading View: Preview presentation
• Slide Show View: Full-screen presentation mode

Exercise:
• Open PowerPoint and identify each interface element
• Switch between different views and observe the changes



Creating and Saving Presentations

Title: Starting Presentation
Content:
• Creating a New Presentation:

• Click File → New
• Choose from: Blank Presentation, Theme Templates, or Online Templates
• Blank Presentation: Start from scratch with customization
• Templates: Pre-designed themes for consistent look

• Saving Your Work:
• First Time Save: File → Save As
• Choose location: Computer, OneDrive, or specific folder
• Enter meaningful file name (e.g., "EE_Project_Presentation_2025")
• Select file format: .pptx (default), .pdf, .ppt (older versions)



Creating and Saving Presentations

• Auto-Save Feature:
• Enable AutoRecover: File → Options → Save
• Set AutoSave interval (recommended: 5-10 minutes)

• File Formats:
• .pptx: Standard PowerPoint format (2007 and later)
• .pdf: Non-editable, universal viewing format
• .ppsx: PowerPoint Show (opens directly in presentation mode)

Exercise:
• Create a new blank presentation
• Save it as "My_First_PPT.pptx" in your Documents folder
• Enable AutoSave with 5-minute intervals



Working with Slides - Adding and Managing

Title: Slide Management Essentials
Content:
• Adding New Slides:

• Method 1: Home tab → New Slide button (dropdown for layouts)
• Method 2: Right-click in Slides Pane → New Slide
• Method 3: Keyboard shortcut: Ctrl + M

• Choosing Slide Layouts:
• Title Slide: First slide with title and subtitle
• Title and Content: Most common layout
• Two Content: Compare two elements side-by-side
• Comparison: Two columns with headers
• Blank: Complete customization freedom



Working with Slides - Adding and Managing

• Deleting Slides:
• Select slide in Slides Pane → Press Delete key
• Right-click slide → Delete Slide

• Duplicating Slides:
• Right-click slide → Duplicate Slide
• Useful for maintaining consistent formatting

• Reordering Slides:
• Drag and drop in Slides Pane
• Use Slide Sorter View for easier management

Exercise:
• Add 5 slides with different layouts
• Duplicate slide 3
• Reorder slides by dragging in Slides Pane
• Delete one unnecessary slide



Working with Text and Text Boxes
Title: Adding and Managing Text Content
Content:
• Using Placeholder Text Boxes:

• Click on "Click to add title" or "Click to add text" areas
• Automatically formatted based on slide layout
• Maintain consistent spacing and alignment

• Creating Custom Text Boxes:
• Insert tab → Text Box
• Click and drag to create text box of desired size
• Position anywhere on the slide
• Useful for annotations and labels

• Text Box Properties:
• Resize: Drag corner handles
• Move: Click border and drag
• Rotate: Use rotation handle at top
• Delete: Select border → Press Delete



Working with Text and Text Boxes

• Bullet Points and Lists:
• Increase indent: Tab key or Increase List Level button
• Decrease indent: Shift + Tab or Decrease List Level button
• Change bullet style: Home → Bullets dropdown
• Numbered lists: Home → Numbering button

• Best Practices:
• Use concise bullet points (6-8 words per point)
• Limit to 6-7 bullets per slide
• Avoid full sentences; use key phrases

Exercise:
• Create a slide with a title and 4 bullet points about your engineering specialization
• Add a custom text box with an annotation
• Create a numbered list of 5 steps for a technical process



Text Formatting and Typography

Title: Making Text Clear and Professional
Content:
• Basic Text Formatting:

• Font type: Select font from dropdown (recommended: Arial, Calibri, Tahoma)
• Font size: 28-32pt for titles, 18-24pt for body text
• Bold, Italic, Underline: Use sparingly for emphasis
• Font color: Ensure high contrast with background

• Text Alignment:
• Left: Standard for bullet points
• Center: Good for titles
• Right: Rarely used
• Justify: Distributes text evenly



Text Formatting and Typography

• Line and Paragraph Spacing:
• Home → Line Spacing
• Recommended: 1.5 or 2.0 for better readability
• Adjust spacing before/after paragraphs

• Text Effects:
• Shadow: Adds depth (use subtly)
• Reflection: Creates mirror effect
• Glow: Highlights text with colored border
• Text outline: Defines text boundaries

• Character Spacing:
• Home → Character Spacing
• Expanded: Increases space between letters (useful for titles)



Text Formatting and Typography

• Typography Tips for Technical Presentations:
• Use sans-serif fonts (Arial, Calibri) for screen presentations
• Maintain consistency throughout presentation
• Avoid excessive formatting variations
• Ensure text is readable from 10+ feet away

Exercise:
• Format a slide title with 36pt bold font and subtle shadow
• Format body text with 24pt size and 1.5 line spacing
• Experiment with different font colors (ensure contrast)
• Apply text effects to emphasize a key technical term



Working with Themes and Layouts
Title: Creating Consistent Professional Designs
Content:
• Understanding Themes:

• Pre-designed sets of colors, fonts, and effects
• Ensures visual consistency across all slides
• Professional appearance with minimal effort

• Applying Themes:
• Design tab → Themes gallery
• Hover to preview theme on slides
• Click to apply to entire presentation
• Right-click theme → Apply to Selected Slides

• Theme Components:
• Color scheme: Coordinated color palette
• Font set: Title and body font combination
• Background styles: Solid, gradient, or textured
• Effect styles: Visual effects for shapes and objects



Working with Themes and Layouts

• Customizing Themes:
• Design → Colors → Customize Colors
• Design → Fonts → Customize Fonts
• Design → Background Styles → Format Background

• Variants:
• Different color schemes of the same theme
• Design → Variants section
• Quick way to change overall appearance

• Slide Layouts:
• Home → Layout dropdown
• Change layout without losing content
• Each theme includes multiple layouts



Working with Themes and Layouts

• Recommendations for Engineering Presentations:
• Choose professional, clean themes (Office, Facet, Ion)
• Avoid overly decorative themes
• Use high-contrast color schemes for technical diagrams
• Maintain consistency throughout presentation

Exercise:
• Apply 3 different themes to your presentation and compare
• Select a professional theme suitable for engineering
• Customize the color scheme to match your institution's colors
• Apply different layouts to various slides



Inserting and Working with Images

Title: Adding Visual Elements to Presentations
Content:
• Methods to Insert Images:

• Insert tab → Pictures → This Device (from computer)
• Insert tab → Pictures → Online Pictures (from web)
• Insert tab → Pictures → Stock Images (Microsoft library)
• Drag and drop from file explorer
• Copy-paste from other applications

• Image Types:
• Photographs: JPG, PNG formats
• Graphics and logos: PNG (supports transparency)
• Circuit diagrams: Import from drawing software
• Screenshots: Windows Snipping Tool or Snip & Sketch



Inserting and Working with Images

• Positioning Images:
• Click and drag to move
• Align tools: Picture Format → Align
• Send to back/front: Picture Format → Arrange
• Grid and guides: View → Gridlines (for precise placement)

• Resizing Images:
• Drag corner handles (maintains aspect ratio)
• Avoid dragging side handles (causes distortion)
• Picture Format → Size group (precise dimensions)
• Lock aspect ratio for proportional scaling

• Image Quality:
• Use high-resolution images (minimum 1024×768)
• Avoid excessive enlargement (causes pixelation)
• Compress images: Picture Format → Compress Pictures



Inserting and Working with Images

• Copyright Considerations:
• Use royalty-free images or stock images
• Create your own diagrams and screenshots
• Provide attribution if required

Exercise:
• Insert a circuit diagram image from your computer
• Insert a stock image related to electrical engineering
• Take a screenshot and insert it into a slide
• Resize and position images professionally
• Compress images to reduce file size



Formatting and Editing Images
Title: Enhancing Images for Better Presentations
Content:
• Basic Image Adjustments:

• Picture Format → Corrections
 Brightness: Make image lighter or darker
 Contrast: Adjust difference between light and dark areas
 Sharpness: Enhance or soften image details

• Picture Format → Color
 Saturation: Adjust color intensity
 Tone: Adjust color temperature (warm/cool)
 Recolor: Apply color filters or make grayscale

• Cropping Images:
• Picture Format → Crop
• Drag black handles to remove unwanted areas
• Crop to Shape: Create circular or custom-shaped images
• Aspect Ratio: Crop to specific dimensions (16:9, 4:3)



Formatting and Editing Images
• Image Borders and Effects:

• Picture Format → Picture Border
 Add colored borders to images
 Adjust border width and style

• Picture Format → Picture Effects
 Shadow: Adds depth behind image
 Reflection: Creates mirror effect below
 Glow: Colored border around image
 Soft edges: Feathers image edges
 3-D effects: Adds dimension

• Removing Background:
• Picture Format → Remove Background
• PowerPoint automatically detects subject
• Mark areas to keep (green) or remove (red)
• Useful for product images and technical components



Formatting and Editing Images
• Artistic Effects:

• Apply filters: Pencil sketch, paint brush, watercolor
• Use sparingly in technical presentations

• Image Arrangement:
• Layer multiple images: Bring Forward/Send Backward
• Group objects: Select multiple → Group
• Align and distribute: Align left, center, right, etc.

Exercise:
• Insert an image and adjust brightness and contrast
• Crop an image to focus on specific component
• Add a subtle shadow effect to an image
• Remove background from an image of a component
• Group multiple images together and align them



Basic Animations

Title: Adding Motion to Slide Elements
Content:
• What are Animations?

• Visual effects applied to objects on a slide
• Control how elements appear, move, or disappear
• Draw attention to key points during presentation
• Should enhance, not distract from content

• Types of Animations:
• Entrance: How objects appear (Fade, Fly In, Zoom)
• Emphasis: Draw attention to existing objects (Pulse, Grow/Shrink)
• Exit: How objects disappear (Fade Out, Fly Out)
• Motion Paths: Move objects along defined paths



Basic Animations
• Applying Animations:

• Select object (text box, image, shape)
• Animations tab → Animation gallery
• Click desired animation effect
• Preview: Watch animation automatically

• Animation Pane:
• Animations tab → Animation Pane
• Shows all animations on current slide
• Reorder animations: Drag up or down
• Delete animations: Select and press Delete

• Animation Timing:
• Start options:

• On Click: Animation starts when you click
• With Previous: Starts simultaneously with previous animation
• After Previous: Starts after previous animation completes

• Duration: Speed of animation (0.5-2 seconds typical)
• Delay: Wait time before animation starts



Basic Animations

• Best Practices for Engineering Presentations:
• Use simple, professional animations (Fade, Wipe)
• Avoid bouncy or flashy effects (Bounce, Spin)
• Animate bullet points one at a time for clarity
• Limit to 2-3 animations per slide
• Test animations before presenting

Exercise:
• Create a slide with 4 bullet points
• Apply "Fade In" entrance animation to each bullet point
• Set timing: "After Previous" with 0.5-second duration
• Add "Pulse" emphasis to an important technical term
• Preview animations and adjust timing as needed



Slide Transitions
Title: Creating Smooth Slide Changes
Content:
• What are Transitions?

• Visual effects when moving from one slide to another
• Applied to entire slides (not individual objects)
• Create professional flow between topics
• Different from animations (which affect objects)

• Types of Transitions:
• Subtle: Professional and minimal (Fade, Push, Wipe)
• Exciting: More dramatic (Cube, Flip, Gallery)
• Dynamic Content: Special effects (Conveyor, Rotate)

• Applying Transitions:
• Select slide(s) in Slides Pane
• Transitions tab → Transition gallery
• Click desired transition
• Apply to All: Use same transition throughout



Slide Transitions
• Transition Options:

• Effect Options: Direction and style variations
• Duration: Speed of transition (0.5-2 seconds)
• Sound: Add audio to transitions (use rarely)
• Advance Slide:

• On Mouse Click: Manual control (recommended)
• After: Automatic timing (specify seconds)

• Viewing Transitions:
• Click Preview button to see effect
• Slide Show → From Current Slide (test full experience)

• Transition Tips:
• Use consistent transitions throughout presentation
• Subtle transitions are professional (Fade, Push)
• Avoid sound effects in professional settings
• Manual advance gives you control during presentation
• Time transitions carefully (1-1.5 seconds is ideal)



Slide Transitions

• Recommended for Technical Presentations:
• Fade: Smooth, professional, works in all contexts
• Push: Clean directional change
• Wipe: Simple and clear
• Avoid: Flashy effects that distract from technical content

Exercise:
• Apply "Fade" transition to all slides
• Set duration to 1 second
• Change one slide to use "Push" transition with "From Right" effect
• Test transitions using Slide Show view
• Compare manual vs. automatic slide advance



Slide Master Basics

Title: Understanding Master Slides for Consistency
Content:
• What is Slide Master?

• Template that controls overall design of presentation
• Defines formatting, fonts, colors, and placeholders
• Changes made in master apply to all slides automatically
• Ensures consistency and saves time

• Accessing Slide Master:
• View tab → Slide Master
• Shows hierarchical structure: Master slide and layouts
• Top slide: Master (affects all)
• Below: Individual layouts (Title, Content, etc.)



Slide Master Basics

• Slide Master Components:
• Theme colors and fonts
• Background styles and images
• Footer elements (date, slide number, text)
• Logo placement
• Default text formatting

• Editing Slide Master:
• Select master or layout to edit
• Make changes: fonts, colors, placeholders
• Insert elements: logos, watermarks, backgrounds
• Changes automatically apply to relevant slides



Slide Master Basics

• Common Master Edits:
• Add company/institution logo to all slides
• Change default fonts and sizes
• Modify footer content
• Adjust placeholder positions
• Set consistent bullet styles

• Master Placeholders:
• Title placeholder
• Content placeholder
• Footer placeholders (date, footer text, slide number)
• Custom placeholders (for consistent positioning)

• Closing Slide Master View:
• Slide Master tab → Close Master View
• Return to normal editing mode
• Changes are now visible in presentation



Slide Master Basics

• Benefits for Engineering Students:
• Create template once, use for multiple projects
• Maintain professional consistency
• Save time on formatting
• Easy to update branding across presentation

Exercise:
• Open Slide Master view
• Add your institution's logo to the master slide
• Change default title font to Arial 32pt bold
• Add slide numbers to footer
• Close Master view and observe changes on all slides



Presenting and Viewing Modes

Title: Delivering Presentation Effectively
Content:
• Starting the Presentation:

 Method 1: Slide Show tab → From Beginning (F5)
 Method 2: Slide Show tab → From Current Slide (Shift + F5)
 Method 3: Slide Show icon in bottom-right corner

• Presentation Navigation:
 Next slide: Click mouse, press Space, or Right Arrow
 Previous slide: Press Backspace or Left Arrow
 Go to specific slide: Type slide number + Enter
 End show: Press Esc key



Presenting and Viewing Modes
• Presenter View:

• Available when using multiple displays
• Shows: Current slide, next slide, notes, timer
• Access: Slide Show → Use Presenter View
• Benefits:

 See your notes while audience sees only slides
 Preview upcoming slides
 Track time elapsed
 Navigate slides easily

• Drawing and Annotation Tools:
• Right-click during presentation → Pointer Options
• Pen: Draw on slides during presentation
• Highlighter: Emphasize text
• Laser Pointer: Point without drawing (Ctrl + L)
• Eraser: Remove annotations
• Colors: Choose ink color
• Use for: Emphasizing formulas, circling data, adding notes



Presenting and Viewing Modes

Screen Options During Presentation:
• Black/White screen: B (black) or W (white) key
• Pause presentation temporarily
• Resume: Press any key

• Zoom Feature:
• Magnify portion of slide for detail
• Click slide and zoom into specific area
• Useful for detailed diagrams or small text

• Rehearsing:
• Slide Show → Rehearse Timings
• Practice presentation and record timing
• Review time spent on each slide
• Adjust content if slides take too long



Presenting and Viewing Modes

Exercise:
• Start presentation from beginning
• Practice navigating forward and backward
• Use pen tool to circle an important value
• Activate laser pointer and practice pointing
• Toggle black screen during presentation
• Rehearse timing and review results



Printing and Exporting Presentations

Title: Sharing Your Work in Different Formats
Content:
• Printing Presentations:

• File → Print (or Ctrl + P)
• Print Options:

 Full Page Slides: One slide per page (large)
 Handouts: Multiple slides per page (2, 3, 4, 6, 9)
 Notes Pages: Slides with speaker notes below
 Outline: Text-only view

• Settings:
 Print All Slides / Current Slide / Custom Range
 Color / Grayscale / Pure Black and White
 Collated / Uncollated
 Portrait / Landscape orientation



Printing and Exporting Presentations

• Recommended Print Settings for Students:
• Handouts (3 slides per page): Space for notes on right
• Handouts (6 slides per page): Compact overview
• Grayscale: Saves color ink, remains readable

• Exporting to PDF:
• File → Export → Create PDF/XPS Document
• Benefits:

 Universal format (opens without PowerPoint)
 Preserves formatting exactly
 Smaller file size
 Cannot be easily edited (security)

• Options:
 Standard quality (recommended)
 Minimum size (for email)



Printing and Exporting Presentations

• Exporting to Video:
• File → Export → Create a Video
• Choose quality: Full HD (1920×1080) or lower
• Set timing: Use recorded timings or fixed seconds
• Useful for: Online sharing, automatic playback

• Exporting to Images:
• File → Export → Change File Type → PNG or JPEG
• Exports each slide as individual image file
• Useful for: Websites, social media, documentation

• Package Presentation for CD:
• File → Export → Package Presentation for CD
• Includes fonts and linked files
• Ensures presentation works on other computers



Printing and Exporting Presentations

• Saving in Different PowerPoint Formats:
• .pptx: Standard format (2007 and later)
• .ppt: Compatible with older versions (pre-2007)
• .ppsx: PowerPoint Show (opens directly as presentation)
• .potx: Template format (reusable design)

Exercise:
• Print handouts with 3 slides per page
• Export presentation as PDF
• Save one slide as PNG image
• Compare file sizes of different formats
• Create a PowerPoint Show (.ppsx) version



Best Practices and Summary

Title: Creating Effective Engineering Presentations
Content:
Design Best Practices:

Simplicity: One main idea per slide
Consistency: Use same fonts, colors, layout throughout
Contrast: Ensure text readable against background
Whitespace: Don't overcrowd slides
Visual Hierarchy: Make important elements prominent

Content Guidelines:
Use bullet points, not paragraphs
6×6 rule: Maximum 6 bullets, 6 words per bullet
Support text with visuals (diagrams, charts, images)
Avoid reading slides verbatim
Use technical terminology appropriately



Best Practices and Summary

Engineering-Specific Tips:
Include clear circuit diagrams and schematics
Label all graphs and charts with units
Use equations and formulas when necessary
Present data in tables or visualizations
Include references for technical information
Add slide numbers for easy reference

Common Mistakes to Avoid:
Too much text on slides
Low contrast colors (yellow on white, etc.)
Excessive animations and transitions
Reading directly from slides
Inconsistent formatting
Poor quality images (pixelated)
Missing labels on technical diagrams



Best Practices and Summary
Presentation Delivery Tips:

Practice multiple times
Know your content thoroughly
Maintain eye contact with audience
Use presenter view with notes
Anticipate questions about technical details
Have backup plan (PDF version, printed handouts)

Summary of Key Skills:
✓ Navigate PowerPoint interface confidently
✓ Create and save presentations
✓ Add, delete, and organize slides
✓ Format text professionally
✓ Apply themes and layouts for consistency
✓ Insert and format images effectively
✓ Insert and format images effectively
✓ Use animations and transitions appropriately



Best Practices and Summary
Summary of Key Skills:
✓ Utilize Slide Master for consistency
✓ Present effectively using various modes
✓ Print and export in multiple formats
Exercise - Final Project:
Create a complete 10-slide technical presentation on an electrical engineering topic:
1. Apply professional theme
2. Include title slide with your name
3. Use various layouts appropriately
4. Insert and format at least 3 images/diagrams
5. Apply consistent, subtle transitions
6. Add animations to key points
7. Include slide numbers in footer
8. Practice presenting in Presenter View
9. Export as PDF
10. Print handouts (3 slides per page)



Additional Resources for Students

Online Tutorials:
Microsoft PowerPoint Official Training
YouTube: PowerPoint engineering presentation tutorials
LinkedIn Learning: PowerPoint courses
Practice Activities:
Create presentation templates for future projects
Design presentations for lab reports
Prepare presentations for project proposals
Create instructional presentations for peers
Tips for Continuous Improvement:
Study presentations from conferences and seminars
Request feedback from instructors and peers
Experiment with different design approaches
Build a library of reusable slide templates
Stay updated with PowerPoint new features



Questions &Answers
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