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Photoshop Workflow Optimization
• Introduction to essential workflow tips for improved productivity

• Techniques to resolve lag and enhance Photoshop performance

• Optimizing software behavior through preference settings

• Overview of critical Photoshop shortcuts for efficiency

• Utilizing Actions to automate repetitive tasks

• Improving project consistency with saved processes

• Gaining additional practical tips to streamline editing workflow



Speeding Up Photoshop
• Common Performance Issues

Photoshop slows down on large files, especially on low-RAM or older 

hardware setups

• Use of Purge Command

Accessing Edit > Purge > All to delete cache and history to free up 

memory and improve speed (note: undo history will be lost)

• Memory Usage Settings

Adjusting memory allocation under Edit > Preferences > Performance; 

70% usage is often optimal

• Graphics Processor Configuration

Ensuring Use Graphics Processor is enabled when having a compatible 

GPU; checking and applying settings for better rendering performance



Advanced Settings & System Optimization
• History & Cache Settings

Lower history states (20) reduce memory use; cache levels should 

match project size: small projects (2), large projects (4+)

• Performance Presets

Using built-in presets (Web/UI, Default, Huge Pixel Dimensions) to 

quickly optimize settings for specific workflows

• Clear System Temp Files (Windows)

Running %temp% via the Windows Run dialog to delete unused 

temporary files and recover system space

• Hardware Recommendations

Upgrading RAM (at least 8–16 GB) and using SSD storage for significantly 

improved performance and load times



Photoshop Preferences Overview
• Photoshop Preferences consist of adjustable settings within the software

• Settings determine the behavior and appearance of the application

• Preferences are divided into multiple categories for organization

• General settings include default units, interface language, and auto-save 

options

• Interface preferences control theme, font size, and UI scaling

• Performance settings optimize memory usage and GPU acceleration

• Customization enhances user workflow and software efficiency

• Preferences influence both current and future editing sessions



Methods for Accessing Preferences
• Accessing Preferences via the Menu bar

• Windows users navigate through Edit > Preferences

• macOS users navigate through Photoshop > Preferences

• Preferences window contains grouped sections such as General, 

Interface, and Performance

• Settings are organized logically to facilitate user adjustments

• Changes often require an application restart to take full effect

• Certain preferences can be synced across devices via Adobe Creative Cloud

• Preferences reset can restore default settings when necessary



Synchronization & Management of Preferences
• Adobe Creative Cloud allows synchronization of select preferences

• Syncing enables consistent settings across multiple devices

• Preferences are saved automatically upon closing the software

• Manual resetting addresses errors or corrupted settings

• Backing up preferences is recommended before making extensive changes

• Proper management prevents conflicts during editing sessions

• Performance adjustments can be tailored based on hardware 

specifications

• Preference management contributes to stable and efficient operation



Functional Benefits of Preferences
• Custom settings enhance workflow speed and efficiency

• Performance optimization improves application responsiveness

• Interface customization increases visual comfort and usability

• Auto-save and Recovery options reduce risk of data loss

• Language and Unit settings support diverse user requirements

• GPU and Cache settings impact rendering and tool performance

• Personalized preferences facilitate specialized editing needs

• Mastery of preferences supports overall proficiency in Photoshop use



Introduction to Photoshop Shortcuts
• Photoshop contains hundreds of keyboard shortcuts for efficient workflow

• Shortcuts cover tools, layers, selections, views, and editing

• Tool shortcuts improve speed and reduce reliance on manual selection

• Mastery of shortcuts is essential for professional editing

• Keyboard shortcuts often repeat across similar tool categories

• Learning a few key patterns enables understanding of many shortcuts

• Modifier keys: Shift, Ctrl, Alt enable alternate commands

• Some shortcuts operate differently depending on OS: Ctrl = Cmd on Mac; 

Alt = Option on Mac; Backspace = Delete on Mac

• Demonstrating key tool-based shortcuts in a new A4 project file



Tool Selection Shortcuts
• Move Tool & Artboard Tool: Pressing V to activate

• Brush Tool: Pressing B; includes Pencil, Mixer Brush, Color Replacement

• Crop Tool: Pressing C; includes Slice and Perspective Crop Tools

• Eraser Tool: Pressing E to cycle through Eraser, Background Eraser, Magic 

Eraser

• Pen Tool: Pressing P; includes Curvature and Freeform Pen tools

• Text Tool: Pressing T to activate Horizontal or Vertical Type tools

• Eyedropper Tool: Pressing I to activate color sampling

• Shape Tool: Pressing U; includes Ellipse, Triangle, Polygon, Line, Custom

• Clone Stamp Tool: Pressing S to activate Clone Stamp Tool



Switching Between Similar Tools
• Photoshop allows cycling through tool variations using Shift + [Key]

• Shift + V switching between Move and Artboard Tools

• Shift + B cycling through Brush, Pencil, and Mixer Brush Tools

• This method applies across tool categories (Crop, Shape tools)

• Helps in avoiding manual selection via the toolbar

• Tool cycling works only if the option Use Shift Key for Tool Switch is enabled 

in Preferences

• Navigating to Edit > Preferences > Tools to check or enable this setting



Layer Management Shortcuts
• Ctrl + J: Duplicating selected layer for non-destructive editing

• Ctrl + G: Grouping layers to organize complex documents

• Ctrl + Shift + G: Ungrouping layers for flexibility

• Ctrl + E: Merging selected layer with the one below

• Ctrl + Shift + E: Merging all visible layers

• Ctrl + ] / Ctrl + [: Moving layer up/down in stack

• Ctrl + Shift + ] / Ctrl + Shift + [: Moving layer to top/bottom

• Layer shortcuts enable efficient document organization



Selections & Masking
• Ctrl + A: Selecting all pixels in active layer or canvas

• Ctrl + D: Deselecting current selection

• Ctrl + Shift + I: Inverting selection to modify alternate areas

• Ctrl + Click layer thumbnail: Selecting non-transparent pixels quickly

• Ctrl + Alt + G: Creating clipping mask for precise layer control

• Ctrl + Shift + N: Creating new layer dialog

• Selections are fundamental for targeted edits and masking



Editing & Painting
• Alt + Backspace: Filling selection with foreground color

• Ctrl + Backspace: Filling with background color

• [ and ]: Decreasing/increasing brush size for precision

• Shift + [ / ]: Adjusting brush hardness for soft or hard edges

• Alt + Click: Sampling clone source point for Clone Stamp Tool

• Alt + Shift + Arrow Keys: Offseting or rotating the clone source for advanced 

cloning

• These shortcuts facilitate fast, precise painting and retouching



Opacity & Blending Modes
• Layers must be selected for opacity and blending mode changes to apply

• V: Selecting Move Tool to enable layer shortcut functionality

• Pressing numbers (1–9): Sets opacity (1 = 10%, 4 = 40%)

• Double digits (55) giving exact opacity values (55%)

• Useful in quickly adjusting transparency without using sliders

• Using Shift + + to cycle forward through blending modes

• Using Shift + – to cycle backward through modes

• Allows rapid comparison of blend mode effects

• Helps avoid opening dropdown menus during workflow

• Aids in creative decision-making with visual feedback



View, Navigation, Undo & History
• Ctrl + R: Toggling rulers for precise alignment

• Ctrl + + / Ctrl + -: Zooming in and out on image

• Ctrl + 0: Fitting image to screen for overview

• Spacebar (hold): Temporary Hand Tool to pan canvas

• Rulers and zoom shortcuts enhance detailed work and layout control

• Efficient navigation reduces time lost in large documents

• Ctrl + Z: Undo/Redo last action for quick error correction

• Ctrl + Alt + Z: Stepping backward through history states

• Ctrl + Shift + Z: Stepping forward in history



Contextual Taskbar in Photoshop
• Dynamic toolbar offering options based on active tools, selections, or layers

• Enabling via Window > Contextual Task Bar; position can be reset or moved

• Initially suggests importing an image when canvas is empty

• Displays actions like Select Subject, Remove Background, Transform upon 

image insertion

• Offers Flip Horizontal/Vertical, Done, or Cancel after transformation

• Smart Objects restrict certain options (Fill); must rasterize for full access

• Selection tools trigger Select and Mask panel with refinement options 

• Behavior changes depending on layer type: image, shape, smart object

• Intended to streamline workflow by surfacing context-relevant tools 

automatically



Actions in Photoshop
• Actions serve as automated sequences for repetitive image-editing tasks

• Accessing the Actions panel via Window > Actions or Alt/Option + F9

• Creating a new action set using the folder icon, functioning as a container

• Using the Create New Action button to initiate recording of a task sequence

• Parameters such as name, set, color, and optional shortcut are defined before 

recording

• With Recording enabled, Photoshop logs each command performed by the user

• Example: Filter > Noise > Add Noise applies noise as part of the recorded 

workflow

• Recording concludes with the Stop icon, saving the sequence for reuse



Advanced Actions –Dialogs & Complex Effects
• Executing stored actions by selecting the action and clicking the Play icon

• Using the Toggle Dialog On/Off icon to enable manual adjustment during 

playback

• Actions with dialogs disabled proceed without interruption or customization

• Playback operates on the selected layer or image within the workspace

• Creating complex actions by combining filters and adjustment layers

• Using Filter Gallery > Cutout and Gradient Fill Layers for stylized results

• Recording multiple steps in one sequence to replicate intricate workflows

• Adjusting actions for varying image sizes by enabling dialog prompts

• Understanding that some Photoshop operations may not be recordable



Editing Multiple Images at Once
• Actions must include a save step to enable automation across multiple images

• Starting a new action: record > duplicate image > optionally rename layer

• Applying effects: Filter Gallery (Cutout), Noise (Add Noise), and Gradient Fill

• Saving the file using File > Save As, format set to JPEG, medium quality

• Batch folder setup: one folder for source images, another for processed output

• Initiating batch processing via File > Automate > Batch and selecting action

• Photoshop sequentially applies the recorded action and saves processed images



Workflow Tips & Optimization in Photoshop
• Learning practical tips to enhance the workflow and improving productivity 

through built-in functionalities

• The Eyedropper Tool allows sampling colors beyond the Photoshop canvas, 

including the interface and other applications

• External sampling requires the Color Picker window to be open and the mouse 

button held while dragging outside Photoshop

• The Brush Tool's default circular cursor indicates brush size and shape

• Activating Caps Lock replaces the brush cursor with a precision crosshair, 

affecting other tools like Clone Stamp and Healing Brush

• Cursor appearance is customizable via Preferences, allowing toggling between 

normal and precise modes

• Understanding cursor states improves control during detailed editing tasks



Toolbar Customization & Canvas Rotation
• The Photoshop Toolbar is fully customizable, accessible through the Edit 

Toolbar option in the three-dot menu

• Tools can be added, removed, or rearranged to suit specific workflow needs

• Custom toolbar presets can be saved and restored to maintain consistent setups

• The Rotate View Tool permits non-destructive canvas rotation for ergonomic 

brushwork

• Canvas rotation affects only the view, not the actual image orientation or pixel 

data

• Reset View returns the canvas to the default upright position quickly

• Rotation facilitates natural hand movement when working on curves or masking



Advanced Navigation & Input Field Calculations
• Using the H key to activate a temporary zoom-out navigation window, allowing 

rapid repositioning of the canvas

• Reducing the number of manual zoom and pan actions in large, complex 

projects

• Numeric input fields in Photoshop accept arithmetic expressions (addition, 

subtraction, multiplication, division)

• Calculations within fields enable precise transformations without external 

calculators

• Immediate computation occurs upon confirming the input, streamlining size and 

position adjustments

• Applies to layer properties, transformations, and opacity settings

• Utilizing built-in math operations reduces human error in layout computations



History Panel & Snapshots
• Using the History Panel to maintain a sequential record of all editing steps 

during a session

• Reverting to any prior state by selecting the corresponding history entry

• Temporary history states - reset when the document closes

• The maximum number of history states adjustable in Preferences 

• Using Snapshots to create named, temporary copies of the document state for 

quick comparison

• Multiple snapshots coexisting, offering parallel workflow paths within a single 

session

• Effective use of history and snapshots supports experimentation and error 

correction



Fade Command for Effects
• The Fade command available immediately after applying filters or adjustments

• Located under Edit > Fade [Last Command]; allowing modification of the last 

effect’s opacity and blending mode

• Fade enables subtle refinement without reapplying or undoing the effect

• Supports all standard blending modes used elsewhere in Photoshop layers

• The command applies only if invoked immediately following the filter or 

adjustment

• Useful for softening strong effects, such as blurs or sharpening

• Fade enhancs creative control and non-destructive editing capabilities

• Familiarity with the feature optimizes post-processing efficiency



Workflow - Best Practices
• Color sampling beyond Photoshop to ensure consistent palette usage across 

design elements

• Cursor modes to balance precision and usability during painting and retouching 

tasks

• Toolbar customization to tailor the interface for individual workflow 

preferences

• Canvas rotation and quick navigation to improve ergonomics and productivity

• Arithmetic input in fields to foster precise and error-free transformations

• History and snapshots to maintain a reversible, flexible editing environment

• The Fade command to add non-destructive effect refinement options

• Integrating these features advances efficient, professional Photoshop workflows



Recording & Exporting Workflow Steps
• Photoshop can automatically record and export detailed step-by-step tutorials

• Enable the feature via Edit > Preferences > History & Content Credentials (or 

Ctrl/Cmd + K)

• Activating History Log and selecting Output to Text File

• Choosing the file save location and log detail level

• All editing actions (placing images, cropping, adjustments) recorded in the log

• Recorded log includes layer names, crop dimensions, and applied effects

• The log file can be edited or organized further for clarity

• Using the feature for sharing or archiving detailed editing workflows



Info Bar & Document Details Panel
• Info Bar showing comprehensive file details when clicked and held

• Displaying width, height, color channels, and resolution

• Allowing toggling between different information views: Document Size, Profile, 

Dimensions, etc.

• Showing GPU mode status and measurement scale (1 pixel = 1 pixel)

• Scratching sizes reflect Photoshop’s memory usage and efficiency during 

operations

• Decreasing of Efficiency indicator if system slows under heavy tasks

• Timing shows how long operations take; increasing with project complexity

• Current tool info dynamically updates to show selected tool name and type



PDF Presentations & Fun Customization Features
• Generating multi-page PDF presentations from image files via

File > Automate > PDF Presentation

• Allowing users to add multiple images, set background color, font size, and slide 

timing

• Randomizing or selecting transition effects for slide changes

• The exported PDF plays automatically with timed slide changes

• Toolbar customization: Holding and clicking buttons with Shift reveals fun icons

• Toggling interface color themes via keyboard shortcuts (Shift + Alt/Cmd + Click)

• UI customizations do not affect functionality but add playful elements

• Resetting customizations possible with additional keyboard and mouse 

commands



Introduction to Adobe Libraries
• Adobe Libraries store assets for sharing and reuse across multiple Adobe 

applications (Photoshop, Illustrator, After Effects, Premiere Pro, InDesign, etc.)

• Activating Libraries panel via Window > Libraries in Photoshop

• Libraries can include images, colors, text styles, brushes, and presets

• Creating new libraries by clicking the “+” icon and naming them

• Adding assets by drag-and-drop or using the panel’s add options

• Assets sync automatically across Photoshop, Illustrator, Premiere Pro, etc.

• Linked assets update automatically when edited in their source app

• Embedded assets are independent copies, not linked to the library



Managing Assets in Libraries
• Dragging images into libraries to store and reuse across projects

• Renaming assets by double-clicking their names in the panel

• Colors can be saved to libraries for consistent branding and easily sampled with 

the Eyedropper Tool

• Text styles, including character and paragraph styles, can be saved to libraries 

and reused across projects

• Storing adjustment layers like Lookup Tables and Curves for reuse

• Using Alt/Option + Drag to add embedded (unlinked) assets

• Linked assets show a cloud icon; embedded assets do not

• Assets can be deleted or renamed within libraries for an organized workflow

• Libraries enhance cross-application efficiency and brand consistency



Finding Similar Images & Extracting Patterns
• Using Libraries to find similar images via right-click > Find Similar

• Photoshop searches Adobe Stock for visually similar images

• Similar images appear with watermarks unless purchased via subscription

• Adding images to libraries at low resolution to test usage and composition

• Extract From Image allows creation of patterns and scalable designs

• Adjusting scale, rotation, and pattern types for versatile backgrounds

• Converting images into vector shapes directly within Libraries

• Extracting color themes and gradients from images to enrich asset libraries



Advanced Library Features & Collaboration
• Adding color modes such as Color, Grayscale, Muted, Deep, Bright, and Dark 

to Libraries

• Importing color themes from color.adobe.com for trend-based palettes

• Using Libraries seamlessly across Adobe apps (Photoshop, Illustrator) with 

synced assets

• Creating and applying patterns and vector shapes across projects

• Exporting libraries as files to save or transfer asset collections

• Sharing libraries by inviting collaborators or generating shareable links

• Collaborators can view and add library assets via Adobe CC app or web

• Libraries optimize workflow by centralizing reusable creative assets across 

software



Mock-ups in Photoshop
• Mock-ups present design concepts to clients in a polished, realistic way

• Help in visualizing how designs appear on various media: print, packaging…

• OnBlast.com - a popular free resource for downloading diverse mock-ups

• Coming as Photoshop files with smart object layers for easy design insertion

• Using mock-ups by opening the smart object, placing the design, saving, and it 

updates automatically

• Enabling clients to accurately anticipate the final appearance of the design 

prior to physical production

• Mock-up types encompass logos, billboards, packaging, digital interfaces…

• Advanced practice includes the creation of custom mockups, offering 

complete control over layered composition and design customization



Questions &Answers

Homework
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