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Introduction to Microsoft Excel

What is Microsoft Excel?
Microsoft Excel is a powerful spreadsheet application designed for organizing, analyzing, 
and visualizing data through tables, formulas, and charts. It is the industry standard for 
data management and numerical analysis.
Why Excel for Electrical Engineering Students?
• Data Organization: Manage experimental measurements and test results systematically
• Calculations: Perform complex engineering calculations with formulas and functions
• Analysis: Analyze circuit parameters, system performance, and statistical data
• Visualization: Create professional charts and graphs for lab reports
• Automation: Automate repetitive calculations and data processing tasks
• Professional Skill: Essential tool in engineering workplace and research
Excel vs. Word:
• Word: Text-focused, document creation, narrative content
• Excel: Data-focused, numerical analysis, calculations, tables
• Integration: Excel data and charts can be embedded in Word documents



Introduction to Microsoft Excel

Course Objectives:
Master fundamental Excel skills including data entry, table creation, basic formatting, and 
data organization essential for engineering coursework and professional practice.
Excel Applications in Electrical Engineering:
• Laboratory data collection and analysis
• Circuit parameter calculations
• Component specification tables
• Project budgeting and resource management
• Statistical analysis of measurements
• Performance tracking and reporting



Excel Interface and Workspace
Excel Window Components:
1. Quick Access Toolbar:
• Located above ribbon (top-left)
• Contains frequently used commands (Save, Undo, Redo)
• Customizable: Add commonly used commands
2. Ribbon:
• Tabbed interface containing all Excel commands
• Main tabs: Home, Insert, Page Layout, Formulas, Data, Review, View
• Contextual tabs appear when specific objects selected (charts, tables, pictures)
• Organized into groups (Clipboard, Font, Alignment, Number, etc.)
3. Formula Bar:
• Displays content of active cell
• Shows formulas (not just results)
• Used for entering and editing cell content
• Name Box (left side) shows active cell address



Excel Interface and Workspace

4. Worksheet Area:
• Grid of cells where data is entered
• Columns labeled A, B, C... (up to XFD - 16,384 columns)
• Rows numbered 1, 2, 3... (up to 1,048,576 rows)
• Active cell highlighted with border
5. Sheet Tabs:
• Located at bottom of window
• Switch between worksheets in workbook
• Add, delete, rename, and reorder sheets
6. Status Bar:
• Bottom of window
• Shows information about selected data (Sum, Average, Count)
• View buttons (Normal, Page Layout, Page Break Preview)
• Zoom slider



Understanding Workbooks, Worksheets, and Cells

Workbook:
• An Excel file containing one or more worksheets
• File extension: .xlsx (Excel 2007 and later) or .xls (older versions)
• Can contain multiple related worksheets for organized data management
• Example: Lab_Report_Project1.xlsx
Worksheet (Sheet):
• Individual spreadsheet within workbook
• Grid of cells organized in rows and columns
• Default: New workbooks contain one worksheet (Sheet1)
• Can add multiple sheets for different data sets or analyses
• Rename sheets with descriptive names (Data, Calculations, Charts, Results)



Understanding Workbooks, Worksheets, and Cells

Cell:
• Basic unit of Excel worksheet
• Intersection of row and column
• Identified by cell reference (column letter + row number)
• Examples: A1, B5, Z100, AA1
• Can contain text, numbers, formulas, or remain empty
Cell Reference:
• A1: Column A, Row 1 (first cell in worksheet)
• C5: Column C, Row 5
• AB100: Column AB, Row 100
• Used in formulas to reference data from other cells



Understanding Workbooks, Worksheets, and Cells

Active Cell:
• Currently selected cell with highlighted border
• Cell reference shown in Name Box
• Content displayed in Formula Bar
• Ready for data entry or editing
Range:
• Group of adjacent cells
• Notation: TopLeft:BottomRight
• Examples: A1:A10 (column range), B2:D5 (rectangular range), A:A (entire column), 1:1 
(entire row)



Navigating Excel Worksheets

Mouse Navigation:
• Click cell: Select and make active
• Scroll bars: Move through large worksheets
• Scroll wheel: Vertical scrolling
• Ctrl + Scroll wheel: Zoom in/out
• Click sheet tab: Switch between worksheets
Keyboard Navigation:
• Arrow keys: Move one cell in direction
• Tab: Move right one cell
• Shift + Tab: Move left one cell
• Enter: Move down one cell (or complete entry)
• Shift + Enter: Move up one cell
• Home: Move to column A in current row
• Ctrl + Home: Move to cell A1 (beginning of worksheet)



Navigating Excel Worksheets

Keyboard Navigation (continuation):
• Ctrl + End: Move to last used cell in worksheet
• Ctrl + Arrow key: Jump to edge of data region
• Page Up/Page Down: Move one screen up/down
Go To Command:
• Press Ctrl + G or F5
• Enter cell reference (e.g., Z500)
• Click OK to jump directly to cell
• Useful for large worksheets
Name Box:
• Click Name Box (left of Formula Bar)
• Type cell reference (e.g., D25)
• Press Enter to navigate directly



Navigating Excel Worksheets

Selecting Ranges:
• Click and drag: Select rectangular range
• Shift + Click: Select from active cell to clicked cell
• Ctrl + Click: Select non-adjacent cells
• Shift + Arrow keys: Extend selection
• Ctrl + A: Select entire worksheet
• Click column header: Select entire column
• Click row header: Select entire row



Data Types in Excel

1. Numbers (Numeric Data):
• Integers: 1, 25, 100, -50
• Decimals: 3.14, 0.5, -2.75
• Scientific notation: 1.5E+10 (1.5 × 10¹⁰)
• Right-aligned by default
• Used in calculations and formulas
• Engineering examples: Voltage values, resistance, current, frequency
2. Text (String Data):
• Letters, words, sentences
• Numbers treated as text (if preceded by apostrophe or formatted as text)
• Left-aligned by default
• Not used in calculations
• Examples: Component names, descriptions, labels, units
• Engineering examples: "Resistor", "Voltage Source", "Test 1"



Data Types in Excel

3. Dates and Times:
• Stored as numbers internally (days since January 1, 1900)
• Displayed in various formats (1/15/2024, 15-Jan-24, January 15, 2024)
• Time: 2:30 PM, 14:30, 2:30:45 PM
• Used in calculations (date differences, time elapsed)
• Engineering examples: Experiment dates, measurement timestamps
4. Formulas:
• Begin with equals sign (=)
• Perform calculations using cell references, operators, and functions
• Display result in cell, formula shown in Formula Bar
• Examples: =A1+B1, =SUM(A1:A10), =B2C2
• Engineering examples: =V/R (Ohm's Law), =PT (Energy calculation)



Data Types in Excel

5. Boolean (Logical):
• TRUE or FALSE values
• Result of logical comparisons
• Used in conditional formulas
• Examples: =A1>B1, =AND(A1>0, B1<100)



Entering Data in Excel

Basic Data Entry:

1. Click cell to select (becomes active cell)

2. Type data (number, text, or formula)

3. Press Enter to confirm and move down

4. Or press Tab to confirm and move right

5. Or click green checkmark in Formula Bar

Editing Cell Content:
• Double-click cell: Edit directly in cell
• Click cell, then Formula Bar: Edit in Formula Bar
• Press F2: Edit mode in cell
• Make changes, press Enter: Confirm edits
• Press Esc: Cancel edits



Entering Data in Excel

Deleting Cell Content:
• Select cell(s): Click or drag to select
• Press Delete key: Clears content (keeps formatting)
• Press Backspace: Clears content and enters edit mode
• Right-click → Clear Contents: Clears content only
• Home tab → Editing group → Clear: Options for content, formats, comments, or all
Replacing Cell Content:
• Select cell
• Type new data
• Press Enter
• Old content completely replaced



Entering Data in Excel

Entering Same Data in Multiple Cells:

1. Select range of cells

2. Type data

3. Press Ctrl + Enter

4. Data appears in all selected cells

Engineering Example - Creating Resistor Table:
• A1: "Resistor"
• B1: "Value (Ω)"
• C1: "Tolerance (%)"
• A2: "R1", B2: 1000, C2: 5
• A3: "R2", B3: 2200, C3: 5



AutoFill and Fill Handle

Fill Handle:
• Small square at bottom-right corner of active cell or selection
• Cursor changes to black crosshair when hovering over fill handle
• Drag to copy or extend data to adjacent cells
Copying Data with Fill Handle:

1. Enter data in cell (e.g., "Test 1" in A1)

2. Select cell

3. Drag fill handle down or right

4. Data copied to dragged cells

AutoFill - Extending Series:
Excel recognizes patterns and extends series automatically:
Number Series:
• Enter 1, 2 in A1:A2 → Select both → Drag fill handle → Continues 3, 4, 5...
• Enter 5, 10 in A1:A2 → Select both → Drag → Continues 15, 20, 25...



AutoFill and Fill Handle

Date Series:
• Enter date in A1 → Drag fill handle → Increments by day
• Enter "Monday" → Drag → Continues Tuesday, Wednesday...
• Enter "Jan" → Drag → Continues Feb, Mar, Apr...
Text with Numbers:
• Enter "Test 1" → Drag → Continues Test 2, Test 3, Test 4...
• Enter "Sample A" → Drag → Continues Sample B, Sample C...
Custom Lists:
• File → Options → Advanced → Edit Custom Lists
• Create custom series for repeated data entry



AutoFill and Fill Handle

Fill Options:
After dragging fill handle, AutoFill Options button appears:
• Copy Cells: Duplicate exact content
• Fill Series: Continue pattern
• Fill Formatting Only: Copy format, not content
• Fill Without Formatting: Copy content, not format
Engineering Application:
Creating measurement sequence: Time (s): 0, 1, 2, 3... or Frequency (Hz): 100, 200, 300...



Flash Fill - Intelligent Data Entry

What is Flash Fill?
Excel feature that automatically detects patterns in data entry and completes remaining 
cells based on examples provided. Available in Excel 2013 and later.
How Flash Fill Works:

1. Enter example(s) in column adjacent to source data

2. Start typing second example

3. Excel detects pattern and suggests completion

4. Press Enter to accept suggestion

5. Or Data tab → Data Tools group → Flash Fill (Ctrl + E)

Common Flash Fill Applications:
Combining Data:
• First Name (A) + Last Name (B) → Full Name (C)
• Example: A1: "John", B1: "Smith" → C1: "John Smith"



Flash Fill - Intelligent Data Entry

Combining Data (continuation):
• Type "John Smith" in C1, start typing next name in C2
• Flash Fill suggests completion for remaining rows
Splitting Data:
• Full Name → First Name and Last Name
• Email → Username and Domain
• Date → Day, Month, Year components
Formatting Data:
• Phone numbers: 1234567890 → (123) 456-7890
• Dates: 01152024 → 01/15/2024
• Text case: john smith → John Smith
Extracting Data:
• Extract numbers from text: "Resistor 1000 Ohm" → 1000
• Extract text from mixed content



Flash Fill - Intelligent Data Entry

Engineering Example:
Component codes: "R1K5" → Extract "R" (type), "1.5" (value), "K" (multiplier)

Limitations:
• Requires clear, consistent patterns
• May not work with complex or irregular patterns
• Always verify results for accuracy
Manual Flash Fill:
If automatic suggestion doesn't appear, use Data tab → Flash Fill or Ctrl + E



Data Validation - Controlling Data Entry

What is Data Validation?
Feature that restricts the type of data or values users can enter into cells, ensuring 
data accuracy and consistency.
Why Use Data Validation?
• Prevent data entry errors
• Ensure consistency in data format
• Limit choices to valid options
• Improve data quality for analysis
• Provide guidance to users
Setting Up Data Validation:

1. Select cell(s) where validation should apply

2. Data tab → Data Tools group → Data Validation

3. Data Validation dialog opens

4. Settings tab: Choose validation criteria



Data Validation - Controlling Data Entry

Setting Up Data Validation (continuation):

5. Input Message tab: Optional message when cell selected

6. Error Alert tab: Message when invalid data entered

7. Click OK

Validation Criteria Types:
1. Whole Number:
• Restrict to integers only
• Set conditions: between, not between, equal to, not equal to, greater than, less 
than
• Example: Test scores between 0 and 100
2. Decimal:
• Allow decimal numbers with conditions
• Example: Voltage measurements between 0.0 and 5.0



Data Validation - Controlling Data Entry

3. List:
• Dropdown menu with predefined choices
• Source: Type values separated by commas, or reference cell range
• Example: Component types: "Resistor, Capacitor, Inductor, Diode"
4. Date/Time:
• Restrict to valid dates or times within range
• Example: Experiment dates in current semester
5. Text Length:
• Limit number of characters
• Example: Student ID must be exactly 8 characters
6. Custom:
• Use formula for complex validation rules
• Example: =A1>B1 (value must be greater than another cell)



Creating Excel Tables

What is an Excel Table?
Structured range of data with special features for managing, analyzing, and 
formatting related information. Tables provide enhanced functionality compared to 
regular cell ranges.
Benefits of Excel Tables:
• Automatic formatting with professional styles
• Built-in filtering and sorting
• Structured references in formulas (use column names instead of cell references)
• Automatic expansion when adding data
• Easy chart creation
• Total row for quick calculations
Creating a Table van be done by 3 Methods:
Method 1 - Insert Table
Method 2 - Format as Table
Method 3 - Keyboard Shortcut



Creating Excel Tables

Method 1 - Insert Table:

1. Select data range (including headers)

2. Insert tab → Tables group → Table

3. Create Table dialog appears

4. Verify range and check "My table has headers"

5. Click OK

6. Data converted to table with default style

Method 2 - Format as Table:

1. Select data range

2. Home tab → Styles group → Format as Table

3. Choose table style from gallery

4. Create Table dialog appears

5. Verify range and headers option

6. Click OK



Creating Excel Tables

Method 3 - Keyboard Shortcut:

1. Select data range

2. Press Ctrl + T or Ctrl + L

3. Create Table dialog appears

4. Confirm and click OK

Table Design Tab:
When table is selected, Table Design contextual tab appears with options for:
• Table styles and formatting
• Table style options (header row, total row, banded rows/columns)
• Convert to range (remove table functionality)
• Remove duplicates
• Resize table



Working with Excel Tables

Table Structure:
• Header Row: Column names (automatically bold and filtered)
• Data Rows: Information organized in rows
• Total Row: Optional row for aggregate calculations
• Sizing Handle: Bottom-right corner for resizing table
Adding Data to Tables:
• New Row: Click cell below last row, start typing (table expands automatically)
• New Column: Click cell to right of last column, add header and data
• Tab Key: In last cell of row, press Tab to create new row
• Insert Rows: Right-click row → Insert → Table Rows Above
Table Style Options:
Table Design tab → Table Style Options group:
• Header Row: Show/hide column headers



Working with Excel Tables

Table Style Options (continuation):
• Total Row: Add row with aggregate functions (SUM, AVERAGE, COUNT, etc.)
• Banded Rows: Alternating row colors for readability
• First Column: Emphasize first column (bold)
• Last Column: Emphasize last column
• Banded Columns: Alternating column colors
• Filter Button: Show/hide filter dropdowns in headers
Renaming Tables:
• Select table
• Table Design tab → Properties group → Table Name
• Enter descriptive name (no spaces, must start with letter)
• Example: "ResistorData", "TestResults", "ComponentList"



Working with Excel Tables

Converting Table to Range:
• Table Design tab → Tools group → Convert to Range
• Removes table functionality, keeps formatting
• Use when table features no longer needed
Structured References:
Tables use column names in formulas instead of cell references:
• Regular formula: =SUM(B2:B10)
• Table formula: =SUM(Table1[Value])
• More readable and maintains reference when rows added/deleted



Sorting Data in Excel

Why Sort Data?
• Organize data in meaningful order
• Find specific information quickly
• Identify patterns and trends
• Prepare data for analysis
• Create professional reports
Sorting Single Column – Two methods:
Method 1 - Quick Sort
Method 2 - Filter Dropdown
Method 1 - Quick Sort:

1. Click any cell in column to sort

2. Home tab → Editing group → Sort & Filter

3. Choose "Sort A to Z" (ascending) or "Sort Z to A" (descending)

4. Or Data tab → Sort & Filter group → A-Z or Z-A buttons



Sorting Data in Excel

Method 2 - Filter Dropdown:

1. Select data range or table

2. Data tab → Sort & Filter group → Filter

3. Click dropdown arrow in column header

4. Choose "Sort A to Z" or "Sort Z to A"

Sort Order:
• Ascending (A to Z): Numbers: smallest to largest; Text: A to Z; Dates: oldest to 
newest
• Descending (Z to A): Numbers: largest to smallest; Text: Z to A; Dates: newest to 
oldest
Sorting Multiple Columns:

1. Select data range (including all related columns)

2. Data tab → Sort & Filter group → Sort



Sorting Data in Excel

Sorting Multiple Columns (continuation):

3. Sort dialog opens

4. Choose first sort column and order

5. Click "Add Level" for additional sort criteria

6. Set second, third sort levels as needed

7. Click OK

Example - Engineering Component List:
• Primary sort: Component Type (A to Z)
• Secondary sort: Value (smallest to largest)
• Result: Components grouped by type, values ordered within each type
Sort Options:
• Sort by: Values, Cell Color, Font Color, Cell Icon
• Custom sort order: Define specific order (not alphabetical)
• Case sensitive: Distinguish uppercase and lowercase



Filtering Data in Excel

What is Filtering?
Temporarily hide rows that don't meet specified criteria, displaying only data that 
matches filter conditions. Original data remains intact.
Enabling AutoFilter:

1. Select data range or click in table

2. Data tab → Sort & Filter group → Filter

3. Dropdown arrows appear in header row

4. Or Home tab → Editing group → Sort & Filter → Filter
Basic Filtering:

1. Click dropdown arrow in column header

2. Uncheck "(Select All)" to deselect all items

3. Check specific items to display

4. Click OK

5. Only rows with selected values shown

6. Filtered column shows funnel icon



Filtering Data in Excel

Text Filters:
Click dropdown → Text Filters → Choose condition:
• Equals / Does Not Equal
• Begins With / Ends With
• Contains / Does Not Contain
• Custom Filter: Combine multiple conditions with AND/OR
Number Filters:
Click dropdown → Number Filters → Choose condition:
• Equals, Does Not Equal
• Greater Than, Greater Than or Equal To
• Less Than, Less Than or Equal To
• Between (specify range)
• Top 10 (top/bottom N items or percent)
• Above/Below Average



Filtering Data in Excel

Date Filters:
Click dropdown → Date Filters → Choose condition:
• Equals, Before, After, Between
• Today, Yesterday, Tomorrow
• This Week, Last Week, Next Week
• This Month, Last Month, Next Month
• This Quarter, This Year
• Custom Filter
Clearing Filters:
• Single Column: Click dropdown → Clear Filter From [Column]
• All Columns: Data tab → Sort & Filter group → Clear
• Remove Filter: Data tab → Filter button (toggle off)



Practical Example - Engineering Lab Data Table

Scenario:
Create organized table for recording voltage and current measurements in circuit 
analysis experiment.
Step 1 - Set Up Headers:
• A1: "Measurement #"
• B1: "Input Voltage (V)"
• C1: "Output Voltage (V)"
• D1: "Current (mA)"
• E1: "Power (mW)"
• F1: "Date"
• G1: "Notes"



Practical Example - Engineering Lab Data Table

Step 2 - Enter Sample Data:
• A2: 1, B2: 5.0, C2: 3.3, D2: 15.2, E2: (formula), F2: 11/9/2025, G2: "Normal operation"
• A3: 2, B3: 5.0, C3: 3.2, D3: 14.8, E3: (formula), F3: 11/9/2025, G3: "Normal operation"
• Continue for additional measurements
Step 3 - Convert to Table:

1. Select range A1:G10 (or all data)

2. Press Ctrl + T

3. Confirm "My table has headers"

4. Click OK

5. Choose professional table style
Step 4 - Add Formulas:
• E2: =C2*D2 (Power = Voltage × Current)
• Formula automatically copies to all rows in table



Practical Example - Engineering Lab Data Table

Step 5 - Use AutoFill:
• A2: 1, A3: 2 → Select both → Drag fill handle down → Auto-numbers measurements
• F2: Enter date → Drag down → Dates increment automatically (or copy same date)
Step 6 - Apply Data Validation:
• Select B2:B100 (Input Voltage column)
• Data → Data Validation → Decimal between 0 and 10
• Input Message: "Enter input voltage (0-10V)"
• Error Alert: "Voltage must be between 0 and 10V"
Step 7 - Add Total Row:
• Table Design tab → Table Style Options → Check "Total Row"
• Click cell in Total Row under Current column
• Select "Average" from dropdown
• Repeat for other numeric columns as needed



Best Practices for Data Entry and Tables

Data Entry Best Practices:
Organization:
• One Type of Data Per Column: Don't mix units or data types
• Consistent Headers: Use clear, descriptive column names
• Include Units: Specify units in header (Voltage (V), Time (s))
• No Blank Rows/Columns: Keep data contiguous for proper sorting/filtering
• Start in Cell A1: Begin tables in top-left corner for consistency

Accuracy:
• Validate Data: Use data validation to prevent errors
• Double-Check Entries: Verify critical measurements
• Use Appropriate Precision: Match decimal places to measurement accuracy
• Document Assumptions: Add notes or comments for clarity



Best Practices for Data Entry and Tables

Efficiency:
• Use AutoFill: Leverage patterns for faster entry
• Copy-Paste: Duplicate repeated data
• Flash Fill: Extract or combine data intelligently
• Keyboard Shortcuts: Tab, Enter, Ctrl+Enter for navigation

Table Best Practices:
Design:
• Convert Ranges to Tables: Use table features for enhanced functionality
• Descriptive Table Names: Rename tables meaningfully
• Appropriate Styles: Choose professional, readable table styles
• Total Row: Add for quick aggregate calculations
• Structured References: Use column names in formulas



Best Practices for Data Entry and Tables

Maintenance:
• Regular Updates: Keep data current
• Remove Duplicates: Data tab → Remove Duplicates (for tables)
• Sort and Filter: Organize data for analysis
• Backup Data: Save copies before major changes

Engineering Documentation:
• Label Everything: Clear headers, units, descriptions
• Include Metadata: Date, experimenter, conditions
• Version Control: Save dated versions of data files
• Consistent Formatting: Maintain standards across all worksheets
• Comments and Notes: Document unusual values or observations



Best Practices for Data Entry and Tables

Common Mistakes to Avoid:
• Mixing data types in single column
• Using merged cells (interferes with sorting/filtering)
• Blank rows within data range
• Inconsistent date formats
• Missing units in headers
• Overwriting original data without backup

Professional Habits:
• Save frequently (Ctrl + S)
• Use meaningful file names with dates
• Organize related data in separate worksheets
• Create documentation worksheet explaining data structure
• Test formulas with known values before applying to all data
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