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Introduction to Charts and Data Visualization

What are Charts?
Charts are graphical representations of data that transform numbers into visual formats, 
making patterns, trends, and relationships immediately apparent. They are essential tools 
for communicating technical information effectively.
Why Use Charts in Engineering?
• Visual Communication: Complex data becomes instantly understandable
• Pattern Recognition: Identify trends, anomalies, and relationships quickly
• Professional Presentation: Enhance lab reports, technical papers, and presentations
• Data Analysis: Reveal insights not obvious in raw numbers
• Comparison: Easily compare multiple datasets or conditions
• Decision Making: Support evidence-based conclusions



Introduction to Charts and Data Visualization

Benefits of Excel Charts:
• Integrated with data (automatic updates when data changes)
• Wide variety of chart types for different purposes
• Extensive customization options
• Professional appearance with minimal effort
• Easy to copy into Word documents and PowerPoint presentations
• Interactive features for data exploration
Engineering Applications:
• Circuit Analysis: Voltage-current characteristics, frequency response curves
• Signal Processing: Waveforms, spectrum analysis, filter responses
• Experimental Data: Measurement results, performance comparisons
• Statistical Analysis: Distribution plots, correlation analysis
• Project Management: Timeline charts, resource allocation, progress tracking
• Quality Control: Control charts, capability analysis, trend monitoring



Introduction to Charts and Data Visualization

Course Objectives:
Master fundamental chart creation and formatting skills to effectively visualize 
engineering data, analyze experimental results, and communicate technical findings 
professionally.
Key Principle:
Choose the right chart type for your data and message. Different chart types serve 
different purposes—selecting appropriately is crucial for effective communication.



Understanding Chart Types

Column Charts:  
• Purpose: Compare values across categories
• Orientation: Vertical bars
• Best For: Discrete categories, comparing multiple series
• Engineering Use: Component specifications, test results across conditions, 
performance comparisons
• Example: Comparing voltage output of different power supplies

Bar Charts:
• Purpose: Compare values across categories
• Orientation: Horizontal bars
• Best For: Long category names, ranking data
• Engineering Use: Component rankings, survey results, resource allocation
• Example: Comparing resistance values of different resistor types



Understanding Chart Types

Line Charts:
• Purpose: Show trends over time or continuous variables
• Best For: Time series data, continuous measurements, multiple data series
• Engineering Use: Voltage/current waveforms, temperature over time, frequency 
response
• Example: Plotting voltage vs. time in RC circuit charging

Pie Charts:
• Purpose: Show proportional relationships (parts of whole)
• Best For: Single data series, limited categories (5-7 max)
• Engineering Use: Power distribution, budget allocation, component cost breakdown
• Example: Percentage of total power consumed by each circuit component
• Limitation: Avoid for multiple series or many categories



Understanding Chart Types

Scatter (XY) Charts:
• Purpose: Show relationship between two continuous variables
• Best For: Correlation analysis, experimental data with independent/dependent 
variables
• Engineering Use: I-V characteristics, input-output relationships, calibration curves
• Example: Current vs. voltage in diode characterization
• Key Feature: Both axes are value axes (not category)

Area Charts:
• Purpose: Emphasize magnitude of change over time
• Best For: Showing cumulative totals, contribution to whole over time
• Engineering Use: Cumulative energy consumption, stacked signal components

Combo Charts:
• Purpose: Combine different chart types (e.g., column + line)
• Best For: Comparing different types of data or different scales
• Engineering Use: Actual vs. target values, dual-axis measurements



Chart Components and Terminology

Essential Chart Elements:
1. Chart Area:
• Entire chart including all elements
• Background and border of complete chart
• Can be formatted with fill colors and borders
2. Plot Area:
• Region where data is plotted
• Interior area bounded by axes
• Can have different background from chart area
3. Data Series:
• Set of related data points plotted on chart
• Represented by bars, lines, points, or slices
• Each series has unique color or marker
• Example: Voltage measurements over time = one series



Chart Components and Terminology

4. Data Points:
• Individual values within data series
• Represented by bars, markers, or pie slices
• Can display data labels showing values
5. Axes:
• Horizontal Axis (X-axis, Category Axis): Usually independent variable or categories
• Vertical Axis (Y-axis, Value Axis): Usually dependent variable or values
• Both axes in scatter charts are value axes
6. Axis Titles:
• Labels describing what each axis represents
• Should include units (Voltage (V), Time (s), Frequency (Hz))
• Essential for clarity and professional appearance



Chart Components and Terminology

7. Chart Title:
• Descriptive heading for entire chart
• Should clearly state what chart shows
• Example: "Voltage vs. Time in RC Circuit Charging"
8. Legend:
• Key identifying each data series
• Shows color/marker for each series with label
• Position: Right, top, bottom, left, or overlay
9. Gridlines:
• Horizontal and/or vertical reference lines
• Help read values from chart
• Major gridlines: Main intervals
• Minor gridlines: Subdivisions (optional)



Chart Components and Terminology

10. Data Labels:
• Values displayed directly on data points
• Optional—use when specific values important
• Can show value, percentage, category name, or series name
11. Data Table:
• Optional table below chart showing source data
• Useful when both visual and numeric data needed
Chart Terminology:
• Category: Group or label on category axis (e.g., "Test 1", "Test 2")
• Value: Numeric data plotted on value axis
• Marker: Symbol representing data point in line/scatter chart
• Trendline: Line showing overall pattern in data (linear, polynomial, etc.)



Creating Your First Chart
Methods for creating charts
üMethod 1 - Recommended Charts
üMethod 2 - Specific Chart Type
üMethod 3 - Quick Analysis Tool
üMethod 4 - Keyboard Shortcut
Method 1 - Recommended Charts:
Excel analyzes your data and suggests appropriate chart types.
Steps:

1. Select data range including headers (e.g., A1:B10)

2. Insert tab → Charts group → Recommended Charts

3. Excel displays suggested chart types in dialog

4. Preview each recommendation

5. Select preferred chart

6. Click OK

7. Chart appears in worksheet

Advantages: Excel's AI suggests appropriate chart types based on data structure



Creating Your First Chart

Method 2 - Specific Chart Type:
Directly choose chart type when you know what you want.
Steps:

1. Select data range including headers

2. Insert tab → Charts group

3. Click specific chart type button (Column, Line, Pie, etc.)

4. Choose chart subtype from dropdown gallery

5. Chart appears in worksheet
Chart Type Buttons:
• Column or Bar Chart
• Line or Area Chart
• Pie or Doughnut Chart
• Scatter (X, Y) or Bubble Chart
• Other Charts (Surface, Radar, etc.)



Creating Your First Chart

Method 3 - Quick Analysis Tool:
Fast access to chart options for selected data.
Steps:

1. Select data range

2. Quick Analysis button appears at bottom-right of selection

3. Click Quick Analysis button (or press Ctrl + Q)

4. Click Charts tab

5. Hover over chart types to preview

6. Click to insert preferred chart



Creating Your First Chart

Method 4 - Keyboard Shortcut:
Fastest method for default chart.
Steps:

1. Select data range

2. Press Alt + F1 (embedded chart in worksheet)

3. Or press F11 (chart in new sheet)

4. Excel creates default chart type (usually clustered column)
Important Tips:
• Include Headers: Select column headers for automatic axis labels and legend
• Contiguous Data: Ensure no blank rows/columns in selection
• Multiple Series: Select all related columns for multiple data series
• Non-Adjacent Data: Hold Ctrl while selecting separate ranges



Creating Your First Chart
Example - Creating Voltage vs. Time Chart:
Data:
Steps:

1. Select A1:B6 (including headers)

2. Insert → Recommended Charts

3. Select Line chart

4. Click OK

5. Chart shows voltage increasing over time



Working with Chart Tools

Chart Tools Contextual Tabs:
When chart is selected, two contextual tabs appear in ribbon:
1. Chart Design Tab:
Controls overall chart structure, data, and appearance.
Key Groups:
• Chart Layouts: Quick access to predefined element combinations
• Chart Styles: Color schemes and visual styles
• Data: Edit data source, switch row/column, select data
• Type: Change chart type
• Location: Move chart to new sheet or embed in worksheet



Working with Chart Tools

2. Format Tab:
Controls detailed formatting of individual chart elements.
Key Groups:
• Current Selection: Choose specific element to format
• Insert Shapes: Add shapes to chart
• Shape Styles: Quick formatting for shapes
• WordArt Styles: Text formatting options
• Arrange: Layer order, alignment, grouping
• Size: Precise chart dimensions
Selecting Chart Elements:
Method 1 - Click Element:
• Click directly on element (title, axis, legend, etc.)
• Handles appear around selected element
• Format tab → Current Selection shows element name



Working with Chart Tools

Method 2 - Chart Elements Dropdown:
• Format tab → Current Selection group → Chart Elements dropdown
• Select element from list
• Useful for small or overlapping elements
Method 3 - Keyboard:
• Select chart
• Press Up/Down arrow keys to cycle through elements
Chart Buttons (Right Side of Chart):
Three buttons appear when chart is selected:
1. Chart Elements (+):
• Add, remove, or position chart elements
• Checkboxes for quick element visibility
• Submenu arrow for element options
• Elements: Axes, Axis Titles, Chart Title, Data Labels, Data Table, Error Bars, Gridlines, 
Legend, Trendline



Working with Chart Tools

2. Chart Styles (paintbrush):
• Apply predefined color schemes and styles
• Style tab: Complete chart styles
• Color tab: Color schemes only
3. Chart Filters (funnel):
• Show/hide specific data series or categories
• Temporarily filter chart data without changing source
• Useful for focusing on specific data
Moving and Resizing Charts:
• Move: Click chart area, drag to new location
• Resize: Click chart, drag corner handles (maintain aspect ratio) or side handles
• Precise Size: Format tab → Size group → enter exact dimensions
• Move to New Sheet: Chart Design tab → Location group → Move Chart



Adding and Formatting Chart Elements
Adding Chart Title:

1. Select chart

2. Click Chart Elements button (+) → Check Chart Title

3. Or Chart Design tab → Add Chart Element → Chart Title → position

4. Click title text box and type descriptive title

5. Example: "Capacitor Voltage vs. Time During Charging"

Formatting Chart Title:
• Select title → Home tab → Font formatting (bold, size, color)
• Or right-click title → Format Chart Title → detailed options
• Font, fill, border, shadow, 3D effects
Adding Axis Titles:

1. Chart Elements (+) → Check Axis Titles

2. Or Chart Design → Add Chart Element → Axis Titles

3. Choose Primary Horizontal and/or Primary Vertical

4. Click axis title and type label with units

5. Example: "Time (s)" for horizontal, "Voltage (V)" for vertical



Adding and Formatting Chart Elements

Formatting Axes:
1. Select axis (click on numbers/labels)

2. Right-click → Format Axis

3. Format Axis pane opens with options: 
ÅAxis Options: Bounds (min/max), units, scale, position
ÅTick Marks: Major/minor tick mark style
ÅLabels: Position, number format
ÅNumber: Decimal places, format (general, number, scientific)

Key Axis Settings:
• Minimum/Maximum Bounds: Control axis range (auto or manual)
• Major Unit: Interval between gridlines and labels
• Minor Unit: Subdivisions (if minor gridlines shown)
• Logarithmic Scale: For wide data ranges (decades)
• Values in Reverse Order: Flip axis direction



Adding and Formatting Chart Elements

Adding Legend:
1. Chart Elements (+) → Check Legend

2. Choose position: Right, Top, Bottom, Left

3. Legend shows series names with color/marker
Formatting Legend:
• Select legend → drag to reposition
• Right-click → Format Legend → fill, border, font
• Delete individual legend entry: Select entry → Delete (hides series)

Adding Data Labels:
1. Chart Elements (+) → Check Data Labels

2. Or Chart Design → Add Chart Element → Data Labels → position

3. Positions: Center, Inside End, Outside End, Data Callout

4. Shows values directly on data points



Adding and Formatting Chart Elements

Formatting Data Labels:
• Right-click data label → Format Data Labels
• Label Options: Value, Series Name, Category Name, Percentage
• Number format, font, fill, border
Adding Gridlines:

1. Chart Elements (+) → Gridlines → choose options

2. Primary Major Horizontal (most common)

3. Primary Major Vertical (optional)

4. Minor gridlines for finer divisions
Formatting Gridlines:
• Right-click gridline → Format Gridlines
• Line style, color, width, dash type
• Subtle gridlines (light gray) recommended for professional appearance



Chart Styles and Colors

Applying Chart Styles:
Chart styles are predefined combinations of colors, effects, and formatting that give charts 
professional appearance instantly.
Method 1 - Chart Styles Button:

1. Select chart

2. Click Chart Styles button (paintbrush icon)

3. Style tab shows style thumbnails

4. Hover to preview

5. Click to apply
Method 2 - Chart Design Tab:

1. Select chart

2. Chart Design tab → Chart Styles group

3. Click More button to see full gallery

4. Choose style



Chart Styles and Colors

Style Categories:
• Styles 1-8: Colorful with various effects
• Styles 9-16: Monochromatic with shading
• Each style includes specific color scheme, fonts, and effects
Changing Chart Colors:
Modify color scheme without changing overall style.
Steps:

1. Select chart

2. Chart Styles button → Color tab

3. Or Chart Design tab → Chart Styles group → Change Colors

4. Choose from color schemes: 

ÅColorful: Multi-color palettes
ÅMonochromatic: Single color variations
ÅTheme Colors: Match document theme



Chart Styles and Colors

Manual Color Customization:
1. Select specific data series (click bar, line, or slice)

2. Right-click → Format Data Series

3. Fill & Line options

4. Choose solid fill, gradient, pattern, or picture

5. Select custom color

Formatting Individual Data Points:
1. Click data series once (selects entire series)

2. Click specific data point again (selects only that point)

3. Right-click → Format Data Point

4. Apply unique color or formatting

5. Use to highlight specific values or outliers



Chart Styles and Colors

Color Best Practices:
Professional Appearance:
• Use consistent color scheme throughout document
• Limit to 3-5 colors for clarity
• Ensure sufficient contrast for readability
• Consider colorblind-friendly palettes
Engineering Documentation:
• Match institutional or publication style guidelines
• Use standard colors for specific meanings (red=error, green=pass)
• Ensure charts are readable in black-and-white printing
• Test print preview before finalizing



Chart Styles and Colors

Accessibility:
• High contrast between data series
• Avoid red-green combinations (colorblind consideration)
• Use patterns or markers in addition to colors
• Include legend for color identification
Theme Colors:
• Chart colors automatically match document theme
• Change document theme: Page Layout tab → Themes
• All charts update to match new theme colors



Creating Column and Bar Charts

Column Charts:
Vertical bars comparing values across categories.
When to Use:
• Comparing discrete categories
• Showing changes over time (limited time points)
• Multiple data series comparison
• Emphasizing individual values
Column Chart Subtypes:
1. Clustered Column:
• Multiple series displayed side-by-side
• Easy comparison within and across categories
• Best for: Comparing 2-4 series across categories
• Example: Comparing voltage output of three power supplies under different loads



Creating Column and Bar Charts

2. Stacked Column:
• Series stacked on top of each other
• Shows contribution to total
• Best for: Part-to-whole relationships over categories
• Example: Total power consumption with breakdown by component
3. 100% Stacked Column:
• Stacked columns normalized to 100%
• Shows relative proportions
• Best for: Comparing percentage distribution across categories
• Example: Percentage of total current through each branch
Creating Column Chart:

1. Organize data with categories in first column, values in subsequent columns

2. Select data range including headers

3. Insert → Column Chart → Choose subtype

4. Chart appears with categories on X-axis, values on Y-axis



Creating Column and Bar Charts

Example Data - Component Testing:
Result:
Clustered column chart with
three groups (supplies) and 
three series (tests)



Creating Column and Bar Charts

Bar Charts:
Horizontal bars comparing values across categories.
When to Use:
• Long category names (easier to read horizontally)
• Ranking or ordering data
• Many categories (more vertical space)
• Emphasizing comparison rather than time
Bar Chart Subtypes:
Same as column charts but horizontal orientation:
• Clustered Bar
• Stacked Bar
• 100% Stacked Bar



Creating Column and Bar Charts

Creating Bar Chart:
1. Select data range

2. Insert → Bar Chart → Choose subtype

3. Categories appear on Y-axis (vertical), values on X-axis (horizontal)
Formatting Column/Bar Charts:
Gap Width:
• Select data series → Format Data Series
• Series Options → Gap Width slider
• Smaller gap: Wider bars, more emphasis on values
• Larger gap: Narrower bars, more white space



Creating Column and Bar Charts

Overlap:
• For clustered charts only
• Negative overlap: Bars separated
• Zero overlap: Bars touching
• Positive overlap: Bars overlapping
Engineering Application - Resistor Tolerance:
Chart comparing measured vs. nominal resistance values with tolerance bands visualized 
through error bars or reference lines.



Creating Line Charts

Line Charts:
Show trends and changes over continuous variables, typically time.
When to Use:
• Time series data (measurements over time)
• Continuous data (not discrete categories)
• Showing trends and patterns
• Multiple data series comparison
• Large number of data points
Line Chart Subtypes:
1. Line:
• Lines only, no markers
• Clean appearance for many data points
• Best for: Smooth trends, multiple series



Creating Line Charts

2. Line with Markers:
• Lines with markers at each data point
• Emphasizes individual measurements
• Best for: Fewer data points, highlighting specific values
3. Stacked Line:
• Lines stacked showing cumulative values
• Less common, can be confusing
• Best for: Cumulative totals over time
4. 100% Stacked Line:
• Shows percentage contribution over time
• Best for: Relative proportions changing over time



Creating Line Charts

Creating Line Chart:
1. Organize data with X-values 

(time/independent variable) in first 
column

2. Y-values (measurements/dependent 
variable) in subsequent columns

3. Select data range including headers
4. Insert → Line Chart → Choose subtype
5. Chart shows X-values on horizontal axis, Y-

values on vertical axis

Example Data - RC Circuit Charging:

Result: Line chart showing exponential 
charging curve



Creating Line Charts

Formatting Line Charts:
Line Style:
• Select data series → Format Data Series
• Line options: Solid, gradient, no line
• Width: Thickness (0.75 pt to 6 pt)
• Dash type: Solid, dashed, dotted
• Use different line styles to distinguish series
Markers:
• Format Data Series → Marker Options
• Built-in markers: Circle, square, diamond, triangle, etc.
• Size: Adjust marker size (3-20 points)
• Fill and border: Customize marker appearance
• Use different markers for each series



Creating Line Charts

Smooth Lines:
• Format Data Series → Line → Check "Smoothed line"
• Creates curved lines between points
• Use for: Theoretical curves, trend visualization
• Avoid for: Actual measured data (can misrepresent)
Multiple Series:
• Each series gets unique color and marker
• Legend identifies each series
• Format each series individually for clarity
Engineering Applications:
Waveforms:
• Voltage or current vs. time
• Input and output signals on same chart
• Periodic signals (sine waves, square waves)



Creating Line Charts

Frequency Response:
• Gain vs. frequency
• Phase vs. frequency
• Use logarithmic scale for frequency axis
Temperature Monitoring:
• Temperature vs. time during experiment
• Multiple sensors on same chart
Calibration Curves:
• Sensor output vs. known input
• Linear or polynomial trendline



Creating Pie Charts

Pie Charts:
Show proportional relationships—how parts contribute to a whole.
When to Use:
• Single data series only
• Showing percentage or proportional distribution
• Limited categories (5-7 maximum for clarity)
• Emphasizing one or two segments
• Total equals meaningful whole (100%)
When NOT to Use:
• Multiple data series (use column/bar instead)
• Many categories (becomes cluttered)
• Precise value comparison (column chart better)
• Changes over time (line chart better)



Creating Pie Charts

Pie Chart Subtypes:
1. Pie:
• Standard circular pie chart
• Shows all slices in single circle
2. Exploded Pie:
• Slices separated from center
• Emphasizes individual segments
• Can explode all slices or specific slices
3. Pie of Pie:
• Main pie with secondary pie showing detail of one slice
• Best for: One slice contains multiple small components
4. Bar of Pie:
• Main pie with secondary bar chart showing detail
• Similar to Pie of Pie but uses bar chart



Creating Pie Charts

5. Doughnut:
• Pie chart with hollow center
• Can show multiple series (concentric rings)
• Center space available for labels or totals
Creating Pie Chart:

1. Organize data with categories in first 

column, values in second column

2. Select data range including headers (single 

series only)

3. Insert → Pie Chart → Choose subtype

4. Chart shows slices proportional to values

Example Data - Power Distribution:

Total: 30W
Result: Pie chart showing each 
component's percentage of total power



Creating Pie Charts

Formatting Pie Charts:
Slice Colors:
• Each slice gets unique color automatically
• Format individual slice: Click slice twice → Format Data Point
• Change fill color, add border, apply effects
Exploding Slices:
• Click slice twice to select individual slice
• Drag away from center to explode
• Or Format Data Point → Point Explosion slider (0-100%)
• Use to emphasize important segment
Data Labels:
• Essential for pie charts (show percentages or values)
• Chart Elements (+) → Data Labels → Outside End
• Format Data Labels → Label Options:



Creating Pie Charts

Data Labels (continuation):
o Percentage: Most common for pie charts
o Value: Actual numbers
o Category Name: Slice labels
o Leader Lines: Connect labels to slices

Label Position:
• Center: Inside slice
• Inside End: Near edge inside slice
• Outside End: Outside slice with leader line
• Best Fit: Excel chooses automatically
Rotation:
• Format Chart Area → Series Options → Angle of first slice
• Rotate pie to position important slice at top (12 o'clock)
• Default: First slice starts at 12 o'clock



Creating Pie Charts

Engineering Application - Budget Breakdown:
Project budget pie chart showing percentage allocation:
• Components: 40%
• Labor: 30%
• Testing: 15%
• Documentation: 10%
• Contingency: 5%
Best Practices:
• Sort slices by size (largest to smallest) for clarity
• Use contrasting colors for adjacent slices
• Limit to 5-7 slices maximum
• Combine small slices into "Other" category if needed
• Always include data labels with percentages



Creating Scatter (XY) Charts

Scatter (XY) Charts:
Show relationship between two continuous variables. Both axes are value axes (not 
category).
When to Use:
• Correlation analysis between two variables
• Scientific and engineering data with independent and dependent variables
• Experimental measurements (input vs. output)
• Identifying patterns, trends, or outliers
• Calibration curves
• Characteristic curves (I-V, frequency response)
Key Difference from Line Charts:
• Line Chart: X-axis is category axis (evenly spaced labels)
• Scatter Chart: X-axis is value axis (scaled numerically)
• Result: Scatter charts accurately represent X-Y relationships



Creating Scatter (XY) Charts

Scatter Chart Subtypes:
1. Scatter with Only Markers:
• Points only, no connecting lines
• Best for: Showing correlation, identifying patterns
• Use when: No inherent order or connection between points
2. Scatter with Smooth Lines and Markers:
• Points connected with smooth curved lines
• Best for: Showing trend with actual data points visible
3. Scatter with Smooth Lines:
• Smooth curved lines only, no markers
• Best for: Emphasizing overall trend
4. Scatter with Straight Lines and Markers:
• Points connected with straight line segments
• Best for: Showing progression with data points



Creating Scatter (XY) Charts

5. Scatter with Straight Lines:
• Straight line segments only, no markers
• Best for: Connecting sequential measurements
Creating Scatter Chart:

1. Organize data with X-values (independent 

variable) in first column

2. Y-values (dependent variable) in second 

column

3. Select data range including headers

4. Insert → Scatter Chart → Choose subtype

5. X-values appear on horizontal axis, Y-values 

on vertical axis
Important: First column = X-axis, Second column = 
Y-axis

Example Data - Diode I-V 
Characteristic:

Result: Scatter chart showing 
exponential I-V relationship



Creating Scatter (XY) Charts

Adding Trendlines:
Trendlines show overall pattern in data and can display equation and R² value.
Steps:

1. Select data series in chart

2. Chart Elements (+) → Trendline → More Options

3. Or right-click series → Add Trendline

4. Format Trendline pane opens
Trendline Types:
• Linear: Straight line (y = mx + b)
ÅBest for: Linear relationships

• Exponential: Exponential curve (y = ae^bx)
ÅBest for: Exponential growth/decay

• Logarithmic: Logarithmic curve (y = a ln(x) + b)



Creating Scatter (XY) Charts

ÅBest for: Diminishing returns
• Polynomial: Curved line (y = ax² + bx + c, or higher order)

ÅBest for: Data with peaks and valleys
ÅOrder: 2-6 (higher = more curves)

• Power: Power curve (y = ax^b)
ÅBest for: Proportional relationships

Trendline Options:
• Display Equation on chart: Shows mathematical formula
• Display R-squared value on chart: Shows goodness of fit (0-1, closer to 1 = better fit)
• Set Intercept: Force line through specific Y-intercept
• Forecast: Extend trendline forward or backward
Engineering Application - Sensor Calibration:
Plot sensor output vs. known input, add linear trendline with equation. Use equation to 
convert future sensor readings to actual values.



Creating Scatter (XY) Charts

Formatting Scatter Charts:
• Marker style, size, and color for data points
• Axis scales (linear or logarithmic)
• Gridlines for reading values
• Trendline style and color



Modifying Chart Data

Editing Data Source:
Change which data is included in chart.
Method 1 - Select Data:

1. Select chart

2. Chart Design tab → Data group → Select Data

3. Select Data Source dialog opens

4. Modify data range, add/remove series, edit labels
Select Data Source Dialog Components:
Chart Data Range:
• Shows current data range
• Click button to select new range in worksheet
• Includes all series and categories



Modifying Chart Data

Legend Entries (Series):
• Lists all data series in chart
• Add: Create new series (specify name and values)
• Edit: Modify series name or values
• Remove: Delete series from chart
• Up/Down Arrows: Change series order
Horizontal (Category) Axis Labels:
• Edit category labels
• Click Edit to select new range for labels
Switch Row/Column:
• Swap what's plotted as series vs. categories
• Useful when Excel interprets data incorrectly



Modifying Chart Data

Method 2 - Drag Data Range:
1. Select chart

2. Colored border appears around source data in worksheet

3. Drag corner handles to expand or contract data range

4. Chart updates automatically
Adding Data Series:
Method 1 - Select Data:

1. Chart Design → Select Data → Add

2. Edit Series dialog: 

ÅSeries name: Cell reference or type name

ÅSeries values: Select data range

3. Click OK



Modifying Chart Data

Method 2 - Copy and Paste:
1. Select new data column in worksheet (including header)

2. Copy (Ctrl + C)

3. Select chart

4. Paste (Ctrl + V)

5. New series added automatically
Removing Data Series:

1. Select series in chart (click bar, line, or legend entry)

2. Press Delete

3. Or Chart Design → Select Data → Select series → Remove
Editing Series Name:

1. Chart Design → Select Data

2. Select series → Edit

3. Edit Series dialog → Series name



Modifying Chart Data

Editing Series Name (continuation):
4. Type new name or select cell reference

5. Click OK
Changing Category Labels:

1. Chart Design → Select Data

2. Horizontal Axis Labels → Edit

3. Select range containing new labels

4. Click OK
Switching Rows and Columns:
When Excel plots data incorrectly (series vs. categories swapped):

1. Chart Design tab → Data group → Switch Row/Column

2. Chart reorients data

3. Toggle back if needed



Modifying Chart Data

Hidden and Empty Cells:
1. Chart Design → Select Data → Hidden and Empty Cells

2. Choose how to handle: 

Gaps: Leave gaps in chart

Zero: Plot as zero value

Connect data points with line: Skip empty cells

3. Show data in hidden rows and columns (checkbox)



Chart Design and Layout Options

Quick Layouts:
Predefined combinations of chart elements for instant professional appearance.
Using Quick Layouts:

1. Select chart

2. Chart Design tab → Chart Layouts group → Quick Layout

3. Gallery shows layout thumbnails

4. Hover to preview

5. Click to apply
Layout Elements Included:
• Chart title position
• Axis titles presence and position
• Legend position
• Data labels
• Data table
• Gridlines



Chart Design and Layout Options

Advantages:
• Fast way to add multiple elements
• Professional combinations
• Starting point for further customization
Adding Chart Elements:
Chart Design tab → Add Chart Element button provides access to all elements.
Chart Element Options:
Axes:
• Show or hide primary/secondary axes
• Horizontal and vertical
Axis Titles:
• Primary Horizontal
• Primary Vertical
• Secondary (if applicable)



Chart Design and Layout Options
Chart Title:
• Above Chart
• Centered Overlay
• None
Data Labels:
• None, Center, Inside End, Outside End, Data Callout
• More Data Label Options (detailed formatting)
Data Table:
• With Legend Keys (shows series colors)
• No Legend Keys
• Displays source data below chart
Error Bars:
• Show uncertainty or variability in data
• Standard Error, Percentage, Standard Deviation
• Custom values
• Important for scientific/engineering data



Chart Design and Layout Options

Gridlines:
• Primary Major Horizontal/Vertical
• Primary Minor Horizontal/Vertical
• More Gridline Options
Legend:
• Right, Top, Bottom, Left
• None
• More Legend Options
Lines:
• Drop Lines, High-Low Lines, Up/Down Bars
• Series Lines (for stacked charts)
• Specific to certain chart types
Trendline:
• Linear, Exponential, Logarithmic, Polynomial, Power, Moving Average
• More Trendline Options



Chart Design and Layout Options

Up/Down Bars:
• For line charts with multiple series
• Shows difference between series
Chart Templates:
Save customized chart as template for reuse.
Creating Template:

1. Format chart with desired appearance

2. Right-click chart → Save as Template

3. Name template

4. Save in Templates folder



Chart Design and Layout Options

Using Template:
1. Select data

2. Insert → Recommended Charts → All Charts tab

3. Templates folder

4. Select saved template

5. Click OK
Benefits:
• Consistent appearance across multiple charts
• Save time on repetitive formatting
• Maintain organizational standards



Chart Best Practices for Engineering

Design Principles:
Clarity:
• Clear Title: Descriptive, includes key information
ÅGood: "Capacitor Voltage vs. Time During Charging (R=10kΩ, C=100µF)"
ÅPoor: "Chart 1“
V Axis Labels with Units: Always include units in axis titles
ÅExample: "Voltage (V)", "Time (s)", "Frequency (Hz)“
VReadable Fonts: Minimum 10-11 pt font size
VSufficient Contrast: Dark text on light background or vice versa
VUncluttered: Remove unnecessary elements (excessive gridlines, decorations)

Accuracy:
• Appropriate Scale: Start Y-axis at zero for bar/column charts (avoid misleading scaling)
• Linear vs. Logarithmic: Use log scale for data spanning multiple orders of magnitude
• Honest Representation: Don't manipulate scales to exaggerate differences
• Error Bars: Include when showing experimental data with uncertainty



Chart Best Practices for Engineering

• Significant Figures: Match precision to measurement accuracy
Appropriate Chart Type:
• Comparison: Column or bar chart
• Trend over time: Line chart
• Correlation: Scatter chart with trendline
• Proportion: Pie chart (limited categories)
• Distribution: Histogram or box plot
Professional Appearance:
• Consistent Formatting: Same style across all charts in document
• Color Scheme: Professional, coordinated colors (avoid garish combinations)
• Legend: Clear, positioned appropriately
• Gridlines: Subtle (light gray), only if needed for reading values
• White Space: Adequate margins and spacing



Chart Best Practices for Engineering

Engineering-Specific Guidelines:
Data Integrity:
• Plot actual measured data points (use markers)
• Distinguish between measured data and fitted curves
• Document data source and conditions
• Include sample size or number of measurements
Technical Standards:
• Follow IEEE, ISO, or institutional style guidelines
• Use standard symbols and notation
• Include figure numbers and captions
• Reference charts in text ("as shown in Figure 3")



Chart Best Practices for Engineering

Axis Considerations:
• Independent Variable: Typically X-axis (horizontal)
• Dependent Variable: Typically Y-axis (vertical)
• Multiple Scales: Use secondary axis when comparing different units
• Logarithmic Scales: Common for frequency response, power, gain
Color for Meaning:
• Red: Error, warning, failure
• Green: Pass, success, normal
• Blue: Neutral, information
• Consistent color coding across related charts
Accessibility:
• Readable in black-and-white (test print preview)
• Colorblind-friendly palettes
• Patterns or markers in addition to colors
• High contrast for projection



Chart Best Practices for Engineering

Common Mistakes to Avoid:
Visual Errors:
• 3D effects (distort perception, avoid unless necessary)
• Excessive decoration (chart junk)
• Too many data series (limit to 3-5 for clarity)
• Pie charts with too many slices (>7)
• Missing or unclear labels
Data Errors:
• Truncated Y-axis (misleading comparisons)
• Inconsistent scales across related charts
• Mixing chart types inappropriately
• Plotting categorical data on scatter chart



Chart Best Practices for Engineering

Technical Errors:
• Missing units in axis labels
• Incorrect axis assignment (independent vs. dependent)
• No error bars on experimental data
• Unlabeled trendlines or curves



Practical Engineering Examples

Example 1 - RC Circuit Time Constant 
Measurement
Objective: Visualize capacitor charging in RC circuit
Chart Type: Scatter chart with smooth lines and 
markers
Key Elements:
• Title: "Capacitor Voltage vs. Time (R=10kΩ, 
C=100µF, τ=1s)"
• X-axis: "Time (s)"
• Y-axis: "Voltage (V)"
• Exponential trendline with equation
• Markers showing actual measurements
• Horizontal reference line at 63.2% (one time 
constant)

Data: 

Analysis: Chart clearly shows 
exponential charging characteristic, 
time constant visible at 63.2% of final 
voltage.



Practical Engineering Examples

Example 2 - Component Performance Comparison
Objective: Compare three voltage regulators under 
different load conditions
Chart Type: Line chart with markers
Key Elements:
• Title: "Voltage Regulator Performance Under 
Load"
• X-axis: "Load Current (mA)"
• Y-axis: "Output Voltage (V)"
• Three series (Reg A, B, C) with different colors 
and markers
• Legend identifying each regulator
• Horizontal reference line at 5.0V (target voltage)
• Gridlines for reading values

Data: 

Analysis: Chart shows Regulator B 
has best load regulation, Regulator C 
shows significant voltage drop under 
load.



Practical Engineering Examples

Example 3 - Power Distribution Analysis
Objective: Show how total power is distributed 
among circuit components
Total: 30.0 W
Chart Type: Pie chart
Key Elements:
• Title: "Power Distribution in Embedded System"
• Data labels showing percentages and component 
names
• Processor slice exploded (largest consumer)
• Professional color scheme
• Total power noted in subtitle or caption

Data: 

Analysis: Processor consumes 50% 
of total power, primary target for 
power optimization.



Practical Engineering Examples

Example 4 - Frequency Response Measurement
Objective: Plot amplifier gain vs. frequency
Key Elements:
• Title: "Amplifier Frequency Response"
• X-axis: "Frequency (Hz)" - Logarithmic scale
• Y-axis: "Gain (dB)"
• Smooth line connecting measurements
• Markers at measurement points
• Horizontal reference line at -3dB point (cutoff 
frequency)

Data: 

Analysis: Logarithmic X-axis 
essential for frequency data 
spanning multiple decades. Chart 
shows flat response in passband, 
rolloff at high frequencies.



Practical Engineering Examples

Example 5 - Measurement Statistics
Objective: Compare measurement precision across 
three test methods
Chart Type: Column chart with error bars
Key Elements:
• Title: "Measurement Method Comparison (n=20 
each)"
• X-axis: "Test Method"
• Y-axis: "Measured Voltage (V)"
• Columns showing mean values
• Error bars showing ±1 standard deviation
• Horizontal reference line at 5.0V (true value)
• Target tolerance band (shaded region 4.95-
5.05V)

Data: 

Analysis: Method C shows best 
precision (smallest error bars) and 
accuracy (closest to true value).



Practical Engineering Examples

Key Takeaways:
• Choose chart type based on data and message
• Always include descriptive titles and axis labels with units
• Use appropriate scales (linear vs. logarithmic)
• Add trendlines for correlation analysis
• Include error bars for experimental data
• Maintain professional, consistent formatting
• Test readability in black-and-white
• Reference charts in text with figure numbers
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