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Advanced Typography Tips
• Two main type tools: Horizontal Type Tool and Vertical Type Tool

• Two basic type modes: Point Type (click) and Area/Paragraph Type (click&drag)

• Accessing type options through the Type Menu, offering multiple text 

manipulation features

• Common panels include: Character Panel, Paragraph Panel, and Glyphs 

Panel for fine adjustments

• Text orientation can be toggled between horizontal and vertical formats

• Converting text into a path using Create Work Path; useful for design workflows

• Convert to Shape: transforming text into editable vector shapes with anchor 

points

• Warp Text: applying predefined distortions such as arc, flag, and bulge, with 

control over bend and distortion



Adobe Fonts & Font Management
• Adobe Fonts (formerly Typekit) offers a large font library; accessible via a

Creative Cloud subscription

• Fonts are grouped into families with various styles (bold, italic, condensed)

• Previewing sample text across fonts and adjusting preview size and input

• Using filters to sort by language, style tags (calligraphic, clean), and 

using Variable Fonts

• Variable fonts support dynamic adjustment of properties like weight and width

• Adding fonts by selecting Add Family or individual styles from the Adobe Fonts 

site

• Licensing typically supports both personal and commercial use of Adobe Fonts

• Adobe Fonts interface includes information on font designers and usage rights



Font Classification & Filtering
• Fonts are categorized into types: Serif, Sans Serif, Slab Serif, Script, and

Handwritten

• Filtering fonts based on font family types within Adobe Fonts or locally installed 

fonts

• Font families include multiple variations; filtering by number of styles available 

(23+ styles)

• Additional filtering options include width, height, contrast, and italicization

• Searching fonts by name; not all fonts may be found in Adobe Fonts

• Similar font suggestions may appear when an exact match is not available

• Once a font is added, it becomes immediately available for use within 

Photoshop



Avanced Font Features & Glyph Panel
• Filtering fonts by class, including Monospace, Serif, Sans Serif, etc.

• Marking fonts as favorites, making them easily filterable through a star icon

• Applying filters to show only Adobe Fonts or fonts with similar styles

• The Similar Fonts feature recommends alternatives visually close to the 

selected font

• The Glyphs panel shows alternate character designs within a font family

• Some fonts offer glyphs in Latin, Greek, and other languages, enhancing 

typographic versatility

• Adding glyphs by double-clicking and modifying individual characters artistically

• Avoiding glyphs overuse for readability and aesthetic balance



Identifying Fonts from Images
• Photoshop offers tools to identify fonts from images using Match 

Font and Adobe Fonts

• Starting by opening images from the project folder

• Accessing Match Font feature via Type menu for automatic font detection

• Selecting up to three lines of text for analysis; simpler fonts yield better 

matches

• Photoshop suggests system and Adobe fonts with visual previews for comparison

• Rasterized or flattened text layers can still be analyzed for font detection

• Adobe Fonts allow uploading an image, selecting a text line, and directly 

activating matched fonts

• Font recognition accuracy depends on image clarity, text simplicity, and proper 

selection



Using Styles to Enhance Workflow
• Styles: pre-made layer effects; quickly applied to text, shapes, or image layers

• Accessing the Styles Panel via the Window > Styles menu

• Styles include combinations of effects such as Bevel & Emboss, Stroke, Drop 

Shadow, and Patterns

• Categories include Fabric, Fur, Neutral, and Basics

• Creating a custom style by configuring layer effects in the Layer Style 

Panel and saving via New Style

• Adding custom styles to the library, grouping in folders, reusing across projects

• Importing and exporting styles to enable sharing or selling of unique designs

• Using styles helps streamline design workflows and ensures visual consistency 

across elements



Creating Custom Brushes
• Creating a new, 6x6 inch, 300-ppi document for demonstration

• Brushes in Photoshop are based on luminance: black reveals, white conceals

• Opposite behavior compared to layer masks, where white reveals and black 

conceals

• Drawing desired shapes using the Brush Tool with 100% hardness in black

• Drawing multiple brush shapes on the canvas (dots, lines, strokes)

• Using the Rectangular Marquee Tool to select a shape

• Saving the selection as a custom brush via Edit > Define Brush Preset

• The preview inverts the black-and-white image, turning black shapes into brush 

marks



Using & Enhancing Custom Brushes
• Selecting the custom brush from the Brushes panel and painting on a new layer

• Using Brush Settings to adjust behavior: Shape Dynamics, Scattering, etc.

• Size Jitter changes brush size per stroke; Angle Jitter varies orientation

• Roundness Jitter introduces shape distortion for variation

• Scattering spreads brush marks

• Count adjusts density

• Transfer controls opacity variability per stroke

• Locking Transparent Pixels and rasterizing a shape layer to paint within it

• Exporting brushes via Export Selected Brushes for reuse



Introduction to Puppet Warp Tool
• Puppet Warp allows precise image distortions using a mesh overlay

• Isolating the subject from the background using Object Selection Tool

• Duplicating the subject layer and placing it above a custom background

• Converting the subject layer into a Smart Object for non-destructive editing

• Accessing Puppet Warp via Edit > Puppet Warp

• Pins added at key points (joints) to control movement

• Movement occurs by dragging pins, creating realistic or exaggerated 

deformation

• Modes: Normal (default), Rigid (limited flexibility), Distort (exaggerated 

warping)



Adding Extra Brushes from Adobe
• Adobe provides free, professional-grade brushes with an active Creative Cloud 

subscription

• Accessing via: Brushes Panel > Hamburger Icon > Get More Brushes

• Redirecting to Adobe’s website featuring brush sets by Kyle Webster

• Kyle Webster's brushes: industry-standard, used by major studios like Disney

• Previously paid, now free as part of Adobe's acquisition and integration

• Brush categories include charcoal, halftone, spatter, and many more

• Downloading desired brush packs directly from the Adobe website

• Installing brushes and importing into Photoshop via Import Brushes option



Testing Extra Brushes from Adobe
• Creating a new document (11×8 inches, 300ppi) to test brushes

• Using charcoal brushes for realistic drawing and shading; adjusting flow for 

control

• Halftone brushes provide ready-made tone patterns; ideal for comics and 

stylized effects

• Spatter brushes simulate ink or paint sprays; useful for dynamic textures

• Some brush packs (like halftones) are large and may slow down performance

• Brushes are niche-specific (drawing, texture, tone effects)

• Using blend modes, color adjustments, and flow settings to refine output

• Heavy brushes can be removed to optimize performance (if not used)



Introduction to Perspective Warp Tool
• Perspective Warp Tool enables alignment of objects to existing scene 

perspectives

• Importing images for demonstration (paper box and road background) and 

converting objects to Smart Objects for non-destructive editing

• Navigating to Edit > Perspective Warp to activate the tool interface

• Tool consists of two main modes: Layout (L key) and Warp (W key)

• Creating a mesh by clicking and dragging corner points to match object edges

• Meshes can snap together by aligning sides; blue lines indicate snapping points

• Toggling to Warp mode to adjust perspective by dragging corner handles

• Holding Shift and click to constrain edges to straight lines (highlighted in 

yellow)



Applying Perspective Warp & Additional Edits
• Real-time manipulation to better integrate objects within the scene

• After warping, perspective can be fine-tuned by moving individual points

• Demonstrating edits using the glass building image with dual-sided mesh setup

• Ensuring parallel alignment of lines to enhance realism in transformation

• Final adjustments involve shifting points for a desirable visual effect

• Optional sky cleanup using the Clone Stamp Tool: sampling with Alt (Option) 

and painting affected areas

• Before-and-after comparisons showing the significant impact of this tool

• Perspective Warp supports both creative manipulation and realistic 

compositing



Introduction to Vanishing Point Workflow
• Opening two images: the complex perspective image and the illustration image

• Avoiding using the Perspective Warp Tool due to complexity; using Vanishing 

Point Filter instead

• Unlocking the background layer before applying the Vanishing Point filter

• Accessing the filter via Filter > Vanishing Point to launch the special interface

• Using the Create Plane Tool to define the base perspective grid on the image

• Adjusting plane alignment carefully until the guidelines turn blue, indicating 

valid geometry

• Zooming in for precision; using the Edit Plane Tool for refinements

• The Vanishing Point window includes tools like marquee, stamp, brush, 

eyedropper, zoom, and pan



Transforming Images in Perspective
• Creating additional planes by clicking and dragging from existing ones to build 

full geometry

• Pressing OK to commit the perspective setup after all planes are defined

• Selecting the illustration image using Ctrl/Command + Click on the thumbnail, 

then copying with Ctrl/Command + C

• Creating a new layer and reopening the Vanishing Point Filter

• Pasting the illustration image within the Vanishing Point window

• Using the Transform Tool to resize, rotate, and position the image into the 

defined planes

• Duplicating the image using Alt/Option + Drag to place multiple instances 

within the scene

• Adjusting placements for realism and committing changes by pressing OK



Blending & Masking with Grunge Texture
• Grouping duplicated illustration images and reducing opacity slightly for 

blending harmony

• Importing and unlocking the grunge image; copying it after selecting its 

thumbnail

• Creating a new layer, entering Vanishing Point Filter, and pasting the grunge

• Using the Transform Tool again to align and scale the grunge in perspective

• Committing and copying the grunge layer; pasting into the illustration’s layer 

mask using Ctrl/Cmd + Shift + V

• Inverting the mask with Ctrl/Cmd + I to reveal key illustration details and blend 

the texture

• Using brushes for refining edges and achieving organic blending effects

• Evaluating results with layer visibility toggles



Introduction to 3D in Photoshop
• 3D was a major feature in Photoshop; Adobe began phasing it out in 2022

• Recent Photoshop versions no longer include 3D; older versions required to 

access it

• Functionality depends on compatible graphics hardware; unsupported systems 

may not show 3D even in older versions

• 3D in Photoshop refers to objects with length, breadth, and height - adding 

volume beyond 2D

• The workspace changes when entering the 3D environment; switching back to 

Essentials workspace suggested (after finishing)

• Creating 3D from text using several methods: Type menu, 3D menu, or 3D panel

• After applying 3D to a text layer, depth is visibly added, and specialized 3D 

controls become available



Navigating & Manipulating 3D Layers
• The 3D workspace includes tools for moving, rotating, sliding, and scaling 3D 

objects

• 3D Layers Panel shows components like Scene, Environment, Camera View, 

Infinite Light, and Object Layer

• Each object and light source can be individually manipulated using the 3D 

transform tools

• Editing Mesh, materials, and lighting properties through the Properties panel

• Editing Material layers individually (front, sides) for visual customization

• Filtering environment and lighting; adjusting them

• Right-clicking options on Scene or Object to reveal mesh and material settings

• Understanding these components is essential for full control over 3D 

compositions



Creating 3D Objects from Custom Shapes
• Photoshop allows users to create 3D layers from custom shape layers

• Using Layers Panel to draw, resize, and adjust colors of a custom shape

• Turning the shape into a 3D object via 3D > New 3D Extrusion from Selected 

Layer

• The Properties panel controls extrusion depth and other 3D settings

• Choosing from preset extrusion styles to vary the shape’s appearance

• The Rotation Tool allows 360-degree viewing of the 3D object

• Complex forms like a flower vase can be modeled from simple 2D shapes



Creating 3D Objects from Custom Shapes
• Mesh presets (cube, cone, donut, hat, etc.) for creating 3D from layers

• Choosing 3D > New Mesh from Layer to wrap image textures onto 3D objects

• The Cube Wrap preset applies the texture to all sides, unlike the standard cube

• The Postcard preset creates flat 3D surfaces without depth

• Photoshop supports default 3D models like soda cans, wine bottles, and 

pyramids

• Exporting created 3D layers in formats like OBJ, STL, and Collada for external 

use

• Importing external 3D models (OBJ files from Maya or 3ds Max)



Enhancing Realism - Light, Shadows & Rendering
• Material properties such as metallic, roughness, and opacity affect realism

• Adjusting IBL (Image-Based Light) to match the background lighting and 

reflections

• Controlling shadows through Infinite Light and repositioning with the Move tool 

+ Shift

• Increasing shadow softness for a more natural appearance

• Clicking Render to initiate calculation of lighting, materials, and shadows

• Rendering quality depends on system performance and scene complexity

• Resetting and cropping the image composition to match the perspective of the 

scene

• Accurate shadow alignment is assisted by the Move to View function



Finalizing 3D Object Placement & Mesh Properties
• 3D objects can be rotated, resized, and positioned based on the desired visual 

result

• Rendering final composition to confirm if the object is properly superimposed

• Superimposing involves integrating a 3D object into an existing 2D image

• Toggling shadows: cast shadows refer to those projected onto surfaces

• Shape presets allow for quick alterations like inflation or extrusion depth

• Mesh properties also allow twisting, tapering, and deformation of shapes

• Bevel settings (width, angle) enhance surface detail and realism

• Resetting transformations to return to default object parameters



Lighting, Environment & Scene Settings in 3D
• Light types include infinite light (like sunlight), spotlight, and point light

• Light properties allow shadow softness adjustment and orientation matching 

the view

• Environment settings include ambient color and image-based lighting (IBL)

• Enhancing environmental realism with Shadow, reflection, and ground plane 

controls

• Scene optimizations like bounding box to reduce performance load on complex 

projects

• Viewing modes include wireframe, normals, and line illustration for better 

object control

• Adjusting coordinates for mesh, lights, environment, and overall scene

• 3D Printing Panel available for exporting objects directly to supported printers



Exercise 1
• Open the background image and resize it to 23 inches width to reduce file size

• Create a new layer and apply 3D > New Mesh from Layer > Mesh Preset > Wine 

Bottle

• Navigate to the 3D Layers Panel to manage bottle, label, and cap components

• Adjust the position of the bottle in the scene using the 3D Slide Tool and scale 

appropriately

• Modify cap material: dark red base/interior, 0% roughness, 13% metallic

• Apply Glass Smooth preset to bottle; set base/interior color to magenta 

shades, opacity to 24%

• Edit label texture: insert PNG label, add background and gold strip design

• Set label material: 0% roughness, 16% metallic for light reflection



Exercise 1
• Update the scene environment by copying the background as an IBL (Image-

Based Light) texture

• Reduce environment light intensity to 60%; adjust infinite light with 30% 

shadow softness and 90% intensity

• Test render the scene to preview materials and reflections

• Refine bottle cap: increase metallic to 23% and darken color for realism

• Perform a high-quality final render using JPEG, max quality, retrace final, and 

threshold 5

• Import the rendered image for final edits via Camera Raw Filter

• Enhance clarity, texture, reduce shadow concentration, and adjust 

contrast/vibrance

• Save the edited image; save project file for future adjustments



Creating Gradient 3D with the Mixer Brush Tool
• Setting up a new document (16x11 in, 150 ppi) for demonstration

• Using the Ellipse Tool to draw shapes with different gradient fills

• Duplicating ellipses multiple times to create variety

• Applying distinct gradients to each duplicated ellipse

• Rasterizing all shape layers to enable painting functionality

• Merging rasterized ellipses into a single layer

• Preparing to use the Mixer Brush Tool on this unified layer

• Ensuring Sample All Layers is turned off before sampling



Mixer Brush Settings & Painting Techniques
• Activating the Mixer Brush Tool with the following settings:

- Load: 100%, Flow: 100%, Smoothing: adjustable (5–24%)

• Choosing a preset like Dry Heavy Load to begin

• Alt-clicking to sample gradients from the merged shape layer (Option on Mac)

• Using a drawing tablet for more natural strokes and control

• Creating a new layer for brush strokes to stay non-destructive

• Experimenting with writing and forms to observe the pseudo-3D effect

• Trying different presets (Wet Heavy Mix) for varied results

• Adjusting brush size and smoothing for artistic flexibility



Exercise 2
• Go to File > Open and select the PSD image of the woman dancing

• The subject is already cut out from the background in the file

• Press Ctrl/Cmd + J to duplicate the subject layer

• Select the Mixer Brush Tool and increase brush size to around 370 px

• Hold Alt and click on the clothing to sample colors (yellow, orange, blue)

• Set brush mode to Dry, Heavy Load and create a new layer for painting

• Begin painting colorful strokes around the subject to form an abstract design

• Paint behind the subject, then create new layers for strokes in front



Exercise 2
• Use the Lasso Tool to isolate the hand and lower body for layer separation

• Move layers so strokes appear to pass behind and in front of body parts

• Create a new layer above the stroke layer, clip it to the strokes (Alt + click)

• Add shadows where elements overlap to increase realism and coherence

• Use black brush on a clipped layer to paint shadows subtly

• Apply layer mask to soften harsh edges and remove unwanted lines

• Adjust opacity and blending modes for realistic shadow blending

• Repeat for all key overlap points: hand, body, and head interaction with the 

effect

• Final result is a visually integrated 3D composition achieved using mixer brush 

and shadows



Introduction to Video Editing in Photoshop
• Photoshop supports basic video editing and animation

• Importing videos via File > Open or by drag-and-drop, appearing on 

the Timeline Panel

• The Timeline Panel allows frame-by-frame control and basic video 

manipulation

• Video layers grouped under the Layers panel as a Video Group, enabling 

organization and visibility toggles

• Applying common tools like Crop to videos, just like with images

• Timeline features include:

- Zoom slider for precise editing

- Playback controls and frame rate info (25 fps)

• Videos are made of frames; 25 fps = 25 images per second



Editing Techniques & Enhancements
• Using the scissors icon to cut video clips at specific points

• Deleting unwanted sections to shorten the clip

• Adding audio (MP3) to the timeline for background music

• Audio can be trimmed, volume adjusted, and include fade-in/out effects

• Right-clicking on video for options like:

- Speed and duration adjustments

- Slow motion or fast-forward

• Adding transitions (Fade with White/Black) between clips or at start/end

• Transitions are click-drag elements whose duration can be customized

• Playback may lag initially due to rendering; once cached, it plays smoothly



More Editing Features & Text Animation
• Photoshop video editing has limitations compared to Premiere Pro 

• Playback resolution options: 50% or 100% 

• Importing video/audio files (MP4, MP3) directly into the timeline for editing

• Adding and positioning text layers over video is straightforward; text can be 

resized and aligned

• Applying layer styles to text for visual enhancements

• The stopwatch icon enables keyframe animation for properties like transform 

and opacity

• Keyframes define start and end states for animations (scale increasing or 

opacity fading)

• Photoshop supports simple opacity animation with keyframes to fade text 

in/out



Color Adjustments, Exporting & Workflow Tips
• Adjustment layers like Vibrance and Color Lookup enhancing video colors 

without affecting other layers

• Blending modes adjusting how color adjustments interact with video layers

• Applying additional Photoshop adjustments (levels, curves) but may slow 

performance due to video file size

• Text, shape, and adjustment layers can be grouped and organized

• Exporting videos via the export icon; selecting H.264 format (MP4) for 

compatibility and quality

• Choosing preset quality options; high-quality recommended for final output

• Rendering time varies based on complexity and system resources

• Experimenting with brushes, effects, and animations for creative video editing 



Exercise 3
• Open the project folder and display all file formats for easy selection

• Select the mountain image, sky image, and flying object image

• Import sky and flying object images as Smart Objects to preserve quality during 

transformations

• Place the sky layer below the mountain and scale it appropriately to fit the 

canvas

• Adjust the sky’s brightness using Curves adjustment to enhance the background 

visually

• Resize the canvas to 1920x1920 pixels for manageable animation size

• Enable the Timeline panel and create a new Video Timeline for animation work

• Organize layers properly and hide unused layers for clarity during animation



Exercise 3
• Animate the mountain layer by scaling and moving it to create depth; set 

keyframes for transformation

• Animate the sky layer with subtle movement at slower speed to simulate 

distant background shift

• Animate the flying object layer: scale, rotate, and move it to simulate 

hovering behind the mountain

• Adjust keyframe timing for smooth transitions and realistic speed variations 

between layers

• Preview the animation to allow proper rendering and smooth playback

• Move flying object layer beneath mountain layer to achieve the proper effect

• Save the project as a PSD file for future editing and backup

• Export animation as MP4 video, maintaining quality and manageable file size



Questions &Answers

Homework
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